Q&A plugin search returning an error

When I use the search functionality of the Q&A plugin, I ge the following error:

Warning: Illegal offset type in isset or empty in /home/content/96/6926896/html/wp-includes/post.php on line 811

and it does not take to to a page with any of the questions listed, but rather the normal archive page.

Any idea what might be going on here? Thanks!

  • jeffreygaudette
    • New Recruit

    Thank you for the quick reply. Here are the error details:

    Backtrace from warning 'Illegal offset type in isset or empty' at /home/content/96/6926896/html/wp-includes/post.php 811:

    1. /home/content/96/6926896/html/wp-includes/query.php 2935 calling get_post_type_object()
    2. /home/content/96/6926896/html/wp-includes/query.php 43 calling get_queried_object()
    3. /home/content/96/6926896/html/wp-includes/general-template.php 664 calling get_queried_object()
    4. /home/content/96/6926896/html/wp-includes/general-template.php 565 calling post_type_archive_title()
    5. /home/content/96/6926896/html/wp-content/themes/bp-business/elements/blog-headers.php 11 calling wp_title()
    6. /home/content/96/6926896/html/wp-includes/theme.php 1112 calling require_once()
    7. /home/content/96/6926896/html/wp-includes/theme.php 1088 calling load_template()
    8. /home/content/96/6926896/html/wp-content/themes/bp-business/search.php 13 calling locate_template()
    9. /home/content/96/6926896/html/wp-includes/template-loader.php 43 calling include()
    10. /home/content/96/6926896/html/wp-blog-header.php 16 calling require_once()
    11. /home/content/96/6926896/html/index.php 17 calling require()

    In response to David's question, yes everything else works. FYI, there is a conflict with the wp-polls plugin. This doesn't allow voting, which make sense since they probably tie into the same hooks.

  • scribu
    • Site Builder, Child of Zeus

    I've installed the BP Business theme and I still can't reproduce the error. I'm guessing it's a search-related plugin that's messing with the 'post_type' query variable, transforming it into an array.

    Please try disabling any such plugin and see if the error goes away.

    PS: The conflict with WP-Polls was already reported and fix will be present in the next release.

  • jeffreygaudette
    • New Recruit

    Sorry for not replying sooner. I have been searching high and low to see what code I could be using that is causing the search not to work. Searches for my other custom post types work, so I am not sure. You can mark the issue as resolves since this seems to be a problem with my site alone.

    Thank you very much for checking-in.

    Jeff

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.