q&a updates always makes me nervous

Hi WPMU DEV folks,

I need to share some facts about Q&A plugin. I've tried to fix plugin issues over and over again.

1) Don't break backward compatibility!
I saw that this plugin started to use page-ask-question.php instead of ask-question.php and this kind of changes can break our websites. You don't even specify in changelog. Terrible mistake.

2) Don't break website!
Please check core.php and look the_title hook. You should use is_post_type_archive instead of is_achive. These kind of changes can messed up whole website. Please test over and over again.

3) Think twice before implement
I saw a few logic issues and don't want to specify one by one. Be careful before making changes, and please use filters much as possible.

I hope feedbacks can help to improve. Unfortunately Q&A is one of the worst plugin I've ever used.

Cheers,

  • Sajid
    • DEV MAN’s Sidekick

    Hi Mustafa,
    Hope you are doing good today :slight_smile:

    1) Don't break backward compatibility!

    I don't see this template even in Q&A beta 1 version in default-templates. Its ask-question.php template there.

    2) Don't break website!

    You are right, there should be is_post_type_archive instead of is_archive. I am marking it as confirmed bug and notifying the developer so it can be fixed in future version of this plugin.

    3) Think twice before implement

    I can understand the importance of filters and actions hooks in WordPress development and we do use these as much as possible. But may be this plugin is more of template focus instead of filters/actions hooks.

    Thank you so much for taking time for your valuable feedback and input, I really appreciate that. I will pass along these useful tips to our developer to be taken care of in future.

    Take a very good care of yourself and have a nice day :slight_smile:

    Kind Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.