Q’s regarding multisite setup not working correctly....

okay so I’ve installed WPMU a few days back and here are the known problems thus far:

1.What is the purpose of the MultiDomains link under the setup menu?
2. What does the Domain mapping configuration do? What should be the correct selection for the admin mapping - by the user, mapped or original?
3. Under sites > newdomain.com > dashboard > domain mapping - what should be the value entered into this area. ex. should it be http://www.customerdomain.com, http://customerdomain.com, or http://72.12.15.250? And does this need to match the domain mapping done under the network admin side?
4. How do I change the virtual host on mydedicated server? My sub folder site called mrkabobca.com doesn’t resolve to the ip address i’ve indicated even though the DNS is correct and the settings are also correct in Plesk. Ex. When I visit http://www.mysite.com/mrkabobca/wp-admin.php it works fine and takes me to the CP. But if I want to VIEW the site, no matter what I enter http://www.mysite.com/mrkabobca/ or http://www.mrkabobca.com it doesn’t show the site. Please let me know if there is something I need to do on my server which runs Plesk 8.6.
5. In the past when I did stand alone WP installations, I was able to create an FTP account view the httpdocs folder, add/remove files and folders specific to that domain. Now with WPMU, where do I see the newly created sub-folders so I can do the same thing? Ex. is there a folder somewhere on the main WP installation that houses these folders? http://www.mysite.com/mrkabobca/ should there be a folder within the WP folders of this site??
6. I used the wp import plugin to import the pages, posts and other related settings for mydomain.com. it worked fine and now i’m just fixing the picture link issues. I went to my sub site http://www.mydomain.com/mrkabobca/ and tried to import the data for this site however when I do so I get the kiss of death - the blank white screen. Come to think of it WordPress should change their name to WhitePage! A little humor at this hour is the only thing keeping me awake!!
7. When I was updating one of the imported site pages, I could not find the box at the bottom of the page which housed a chronological order of all the previous versions of that page. So in the event I mess up something I was always able to go back and revert it back. Where has that page gone? Or is it not showing up right now because I just imported this data and there are no previous versions?
8. I tried to install the W3 Total cache but I’m getting errors after downloading it. Do you have a plugin that you think might be better for this situation?

The main thing is that I want to learn the correct steps on how to set up a new domain and have it working properly when I visit that domain.com directly.

Wow there’s a lot of crap I don’t know about the new WPMU! I look forward to your reply.
Thanks for your help and patience.