Questions about Ult. Facebook

I really wanted to post the Facepile widget on my home page. I cannot get anything to display. I am only able to get a few of the functions working. I have the like and share buttons on posts, no problem. But the widgets are problematic. I have gotten the recent activity widget to work so I assume that I am connected properly, but it only shows the items I personally have click “like” on, not anyone else’s. What I really want is to show the Facepile on the homepage and start to auto post to FB from WP. I’m wondering if there’s a showcase anywhere so I can see how others are using the plug in, and I’m wondering if there’s someone who can walk me through the set up to figure out what I’m doing wrong. I would be happy to pay someone to set this up, I’m spending waaaay too much time on something I thought would be a bit simpler and less complex.

  • Patrick
    • Support Monkey

    Hiya @richardm

    Welcome to the forums!

    I’m spending waaaay too much time on something I thought would be a bit simpler and less complex.

    I hear ya! But integrating with Facebook is anything but simple; they keep changing stuff in their APIs and whatnot, and sometimes things don’t necessarily work as smoothly as expected.

    Now that we’re done commiserating, let’s see if we can get to some problem solving :slight_smile:

    Could you first post a screenshot of your “Autopost to Facebook” settings please?

  • RichardM
    • WPMU DEV Initiate

    Same problem. I can’t seem to get past the “grant extended permissions” setting. It just spins and never completes. (See image #2 that I posted before).

    Also, you asked to see a screenshot of my settings for “autopost to FB” and I posted it, but got no response.

    So, yeah, same problems.

  • RichardM
    • WPMU DEV Initiate

    Help? Still need it. Am I doing something wrong? I've been trying to get this plug in to work for weeks, can't get past the "advanced settings" screen, and my definition of "lightning fast" would be within a few hours….certainly within 24 hours..not weeks.

  • Patrick
    • Support Monkey

    Hi @richardm

    You have my deepest apologies for the support delays you have been experiencing. We have implemented some new features and procedures on this site (and in our work habits) to help reduce this type of delay from now on.

    I see in the screenshot you have posted above that all post types have been set to “Don’t post this type to Facebook”. The post types you want to be posted must be set to something (Wall, Events, etc).

    As for the continuous spinning of the loader in the “Extended Permissions” tab, I had a similar experience on a test site until I cleared my browser cache. So please try (if you haven’t already) clearing your browser cache.

    Also, verify if you have any caching plugins or scripts running on your site. Another thing to check is other plugins that connect to Facebook in any way; those scripts may interfere too.

    If all else fails, I could take a look directly to see if I can spot what might be going on. If you can email me your admin login creds, I could login early this afternoon (I leave for the weekend at 5pm EST).

  • RichardM
    • WPMU DEV Initiate

    Patrick, I'm still stuck.

    I've turned off caching plugin; made sure there was nothing else related to FB on the site; and flushed my browser cache repeatedly, but I still can't get past the spnning of "extended permissions" tab….

    I updated the post tabs to have posts show up on my Facebook wall. Doesn't seem to be working either… see screen grabs attached.

    I may have to ask you to log in directly and poke around, if you're still willing.

  • Patrick
    • Support Monkey

    Hey @richardm

    Yes, your account should be visible there in the dropdown beside each post type.

    But the root of the problem is still the extended permissions I think. They haven’t been set or saved yet.

    I’m off to the country again this weekend but, if you would email me your admin login creds, I could take a look at the beginning of the week.

    Use the contact form here and please include the following:

    Attn: Patrick

    Site URL: ________

    Admin username _________

    Pass: ___________

    Link to this thread: ___________

    Let’s try to get to the bottom of this weirdness.

  • Patrick
    • Support Monkey

    Hiya @richardm

    I think I figured out what was going wrong.

    I’m logged into the backend of the site you directed me to in the email you sent and successfully created an app at Facebook. 1st screenshot below shows the app settings at Facebook; 2nd shows the results for Autopost at your site.

    Please check the settings in the 1st screenshot below for the app I created to be sure of the following in your own app (you’ll need to re-enter the App ID & secret at your site):

    – Enter the “App Domain” without the http part.

    – Enter the “Site URL” with the http part.

    – Be sure “Sandbox Mode” is disabled.

    Here’s a step-by-step to be sure your app is properly created: https://premium.wpmudev.org/forums/topic/how-to-make-a-facebook-app

    You’ll also find this link here: https://premium.wpmudev.org/project/ultimate-facebook/#usage

    Hope this helps! And thanks for being a member :slight_smile:

  • RichardM
    • WPMU DEV Initiate

    Hi Ari, thanks for looking into this. No, we haven’t fully resolved all the issues. I was trying to do this work on a test site, and we decided to move the live site to a new server and then install the plugin and try again.

  • Patrick
    • Support Monkey

    Hi @richardm

    I’m doing a bit of housekeeping by going through some older threads, and I noticed this one is still open.

    Just to get it out of our active ticket system, I’m going to mark it resolved.

    But if you still need assistance on this issue, please don’t hesitate to re-open it by checking the “Mark as not resolved” box below.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.