Random 500 internal errors (more prominent when signing up for prosites)

Hi hoping somebody can help me shed some light on a serious issue which is preventing me from launching the service public.

I keep getting random 500 internal server errors, and again yesterday while testing the sign up process following making some changes to only the “text strings” on wp-signup.php.

Is there anything specific I need to be looking at? htaccess? reducing server loads? optimising wordpress?

Thank you in advance. L

  • Jack Kitterhing
    • Code Norris

    Hi there @liam Twose

    I hope you are well today.

    Could you give me a direct link to the signup page so I can test?

    How else have you been editing the signup page? Any PHP?

    Are you running Apache or Nginx?

    Could you tell me your host?

    Could you paste your .htaccess file please so I can take a look.

    Thank you for being a WPMU DEV member!

    Kind Regards

    Jack.

  • Liam Twose
    • Flash Drive

    Hi Jack

    # BEGIN s2Member GZIP exclusions
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{QUERY_STRING} (^|?|&)s2member_file_download=.+ [OR]
    RewriteCond %{QUERY_STRING} (^|?|&)no-gzip=1
    RewriteRule .* - [E=no-gzip:1]
    </IfModule>
    # END s2Member GZIP exclusions

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    The s2member stuff can come out of there as i’ve removed it. Although this was only this morning FYI.

    My live link is here

    I edited the php file via code editor in cpanel. No changes to PHP code, just the text strings i.e. gimme a site! etc

    Apache? i’m with Hostgator on a reseller account.

    Cheers Jack. Your help will be greatly appreciated.

  • Liam Twose
    • Flash Drive

    Hey Ajay,

    Thank you didn’t know of that setting, have set it and no hiccup on first test signup since. Fingers crossed this may have addressed the issue!

    Will test over a period of time and see if any more 500s appear. Unfortunately I’m not sure but in my cpanel it was saying failed to execute script. so sounds like the memory thing could be related.

  • Jack Kitterhing
    • Code Norris

    Hi there @liam Twose

    Thanks for the update and @ajay213 Thanks for providing @liam Twose that information, I would also agree and say this was a memory limit issue, more so than anything you had a execute script fail in cPanel.

    I just tested the signup and it worked fine for me.

    Are you all set up and ready to go with the WP super cache now?

    Thank you both for being WPMU DEV members!

    Kind Regards

    Jack.

  • Liam Twose
    • Flash Drive

    Brilliant, yes seems to have solved it then :slight_smile:

    @jack, already installed WP Super Cache, did the site load fast for you? all compressed also and working fast from tests this end!

    Great stuff glad to be one! Fingers crossed I can launch my product to the public soon. Thanks so much!

  • Jack Kitterhing
    • Code Norris

    Hi Liam,

    Sorry for the delay on this, I missed your last response, I hope you are well today :slight_smile:

    The site loads very fast for me, great job! :slight_smile:

    Hope the site is going well and good luck with the business! If we can be of any further assistance please don’t hesitate to ask.

    Thank you for being a WPMU DEV member and sorry again about the extreme delay.

    Kind Regards

    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.