RE: Appointment+ 'No Preference' option

Hi,

I'm using the Appointments+ plugins with a list of available suppliers. The only issue I have is that the default option for the drop-down is 'No preference'' - how do I go about removing this, so that the first option is the first service provider?

Many thanks.

  • Adam Czajczyk

    Hello Nathan!

    Currently this is not possible with plugin's settings. This little code snippet should do the trick though:

    function wpmu_auto_select_provider() {
        ?>
        <script type="text/javascript">
        jQuery(function($) {
            $("div.app_workers_dropdown_select select").val('1');
        });
        </script>
        <?php
    }
    add_action('wp_footer', 'wpmu_auto_select_provider');

    To apply it to your site first check an ID (on "Appointments -> Settings -> Service Providers" page) of a service provider that you'd like to be selected by default and replace the "1" number with it in this line:

    $("div.app_workers_dropdown_select select").val('1');

    Then add entire code to the functions.php file of your current theme.

    I hope that helps!
    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.