"Read More" option for forum updates that appear in the activity stream

I'm not sure if I've overlooked a setting for this, but for some reason when a Forum Comment appears in the sitewide activity stream, there is no way to expand or view those particular comment from the activity stream. The user had to navigate to that particular forum and then scroll to find the comment so they can view the entire text of the comment.

If someone just make a standard comment, like on their profile, those comments have a "Read More" link and when it is pressed the comment just expands right there and the user can read it.

Do I have to enable something to allow forum comments to be expandable in the activity stream?

I'm using BBPress with Buddypress for my forums functionality.

Thank you!

  • aecnu

    Greetings llasalle1,

    Thank you for the video explaining the error in detail, it is a great help.

    An in depth analysis of this issue has brought me to the conclusion this is being controlled from the comment feed itself on the other end in which we have no control, and they are enabling excerpts of the comment to be used instead of the entire comment.

    I firmly believe this can only be changed on the feeds end.

    Thank you for being a WPMU Dev member!

    If we can be of further assistance please let us know.

    Cheers, Joe :slight_smile:

  • llasalle1

    Hi Joe -

    Upon further investigation, I have found that blog post comments that appear in the activity stream also behave like forum comments, in that they do not have a "read more" option available to expand the comment in the activity stream. This would indicate that it is not a function of BBPress as you indicated previously. It is a function of the activity stream itself. Can you please investigate again?

    Thank you,
    Larry

  • llasalle1

    Hello -

    I agree with what you said about this being an issue with the site wide activity stream. That is why I tried to steer us away from the forum plugin when I provided my last update. Once I saw that comments made to posts also don't have a "read more" option, I realized it can't be the forum. I'm happy to provide details I can help with, but I would bet you could reproduce this by adding a longer comment to a post and then view that comment from the site wide activity stream. I'm using the default buddypress template and bbpress forums.

    Thank you,
    Larry

  • aecnu

    Greetings Larry,

    After re-reading this entire thread it is obvious that it was marked incorrectly from the start as a Forum plugin topic when it was later discovered we were on the wrong trail totally throwing this off the real topic at hand and creating un-necessary work trying to figure out and reproduce the issue stated.

    Now we have come upon the conclusion that it may be the activity stream. Of Buddy Press plugin?
    If so, what advice or solution has Buddy Press offered to this anomaly if any?

    Regarding the marking of the ticket as resolved as evidenced by looking over my comments to this thread. However, it does have the advantage of not aging so much and being brought front and center similar to a new ticket when marked as unresolved.

    I will happily move this off the current topic if I knew what is specifically is related to the activity stream? Perhaps Activity Plus plugin?

    Please advise.

    Cheers, Joe :slight_smile:

  • aecnu

    Greetings llasalle1,

    I am sorry for my miss-communication which is indicated by your response in your last post. I shall clarify for us.

    are you suggesting that I bring this question to Buddypress?

    No I have not suggested this, basically what I was inquiring to is if you have what was there response?

    I feel like we keep hitting dead ends on this issue. I'm happy to open a new thread, but it won't change what we now know, right?

    You are absolutely correct that we do know a little about what is going on here considering the previous posts. What I was trying to point out is that this ticket is indicated as being a Forum plugin issue which after pinging the developer in here for forums he has clearly demonstrated that it is not a Forum plugin issue. Forum developer response: Which forum plugin are you referring to? I think the issue is with site wide activity stream and not the plugin.

    Now the only way to get this resolved is to figure out which plugin of ours is related to the site wide activity stream so that I can get the correct developer to help answer our questions i.e. Perhaps Activity Plus plugin?

    If it is the Activity Plus plugin or any other WPMU Dev plugin I can manually change the topic to that particular plugin and then address the appropriate developer.

    In any event it is not necessary to create a new ticket, but I do need to figure out exactly what we are dealing with to know where to assign this too.

    Please advise if you are using the Activity Plus plugin?

    Cheers, Joe :slight_smile:

  • aecnu

    Greetings llasalle1,

    OK - no I have not ruled anything except that it is not the Forums plugin, and you are further correct that as S H Mohanjith said, it is a problem with the site wide activity stream which is unfortunate news because it falls outside the realm of our plugins.

    I only asked this about the BuddyPress Activity Plus plugin to switch the developer answering hoping to get one of them familiar with the Buddy Press activity stream to comment, as you noticed other then saying it is a problem with the site wide activity stream S H Mohanjith offered no other comment to possibly lead to a solution, though he is also not the authority for this which in fact because it does appear to be a Buddy Press issue - it does not fall under anyone's specific realm here though we try to support other peoples work which can sometimes be extremely challenging to say the least.

    With that said, have you gone through the standard troubleshooting technique of deactivating all plugins and checking to see if it cures the issue? and if so then activating them one at a time and test after each activation to see which one is causing the issue?

    Please advise.

    Cheers, Joe :slight_smile:

  • storyaday

    Did anyone ever figure this out? Is it possible to have a 'read more' on the activity stream posts?

    Most of this discussion seems to be about whether this query is in the right place. Was there a solution to the problem?

    In short: I want my users to be able to see an activity stream excerpt, click on a 'read more' and go directly to that post (whether forum or blog).

    Is WPMUDev not the right place to ask about this?
    Did this discussion move to another forum and get resolved?

  • aecnu

    Greetings storyaday,

    Thank you for the great questions.

    If the problem is in fact within the site wide activity stream itself, as our developer mentioned above, then it would be an issue that only Buddy Press could resolve.

    Though it can be pretty challenging to support other peoples work, we do our best here to help you with any WordPress issues at all.

    Have you by any chance asked about this very anomaly of the Buddy Press forum?

    Now I have gone ahead and done due diligence for answering this question by going to the Buddy Press site and found:
    http://codex.buddypress.org/releases/version-1-5/

    Which tells about that they just added this feature in version 1.5 under the topic User Features --> activity stream though they do not tell there how to enable it, at least we know that they now offer it in 1.5

    Cheers, Joe

  • aecnu

    Greetings Julie,

    Thank you so kindly for letting us know and for your comments about the Buddy Press forums.

    We do our best here in the WPMU Dev forums to help our members but do to this fact, we get plastered with tickets and it does cause delays in getting back to folks due to this very flow and reasons.

    Thank you for being a WPMU Dev Member.

    Please advise if you happen to get any working resolution from BP.

    Have a GREAT weekend!

    Cheers, Joe

  • aecnu

    Greetings Julie,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • storyaday

    Thanks for following up on this. The answer I got in the Buddypress.org forums was too coder-y for me to understand. Can you help translate it for me? here's what someone wrote:

    "? you seem to be referring to a bbPress issue given the link above; forum posts and indeed WP blog posts truncate without a link, BP activity updates however are fine and have an active read more link.

    "The feature you refer to doesn’t mention forums or posts

    "> Add truncation for long posts; adds a “read more” link which dynamically loads the full text (#2635, #3203).

    "Perhaps if you perceive the behaviour as wrong you could open a trac ticket?"

    Now, this doesn't solve my problem or even address it, really, and I don't even know where to begin asking for help after that.

    Any chance you could help me formulate a question that might get me an answer I understand over at Buddypress.org? I am an end user who knows just enough about the back-end to be a little dangerous. I just think there should be an active link on the "..." that I see in my activity stream, and I want to know where the problem lies and who I should contact to get it fixed.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.