Reader Trending Tags MIssing

Sajid mentioned that I should open a new ticket for the Reader and Global Site tags issue I posted about here. The reader trending tags block is not present in Reader. Another issue is that the Reader search function does not produce any results when searching tags.

I've tried disabling all other plug-ins except reader and post-indexer but no luck.

Thanks for your help!

  • Adam Czajczyk

    Hello ict.bwya,

    I hope you're well today and thank you for your question!

    I just tested this on my test setup but I couldn't replicate none of these issues and the Reader plugin is working fine for me. This means that there's some issue on your site that I need to investigate closer.

    In order to be able to do this I'd like to access your site and review its configuration. Would you mind granting me a support access to it so I could take a look? You may grant me an access by following this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know please when you're ready and I'll proceed with troubleshooting.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello ict.bwya!

    Thanks for granting access. I spent a fair amount of time on your site reviewing its settings and running some test. I even reinstalled "Reader" from scratch but so far no luck.

    You mentioned that you already tried to disable all the plugins but it didn't help. Have you also tried to switch to the Twenty Fifteen theme to check if it works then? According to the current settings the "Trending Tags" box should be there.

    That said, I'd like you to try following steps:

    1. as a visitor go through your (sub)sites and visit some tags
    2. add following lines to the "wp-config.php" file of your site:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);
    define('WP_DEBUG_DISPLAY',false);

    3. run through entire theme/plugin conflict test again please as described on a flowchart in this article:

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If at any point "Trending Tags" shows up let me know please when. If it doesn't, please download (via FTP or cPanel File Manager) the "/wp-content/debug.log" file from your server and then rename it to debug.txt and attach to your replay here.

    Best regards,
    Adam

  • ict.bwya

    Hey Adam,

    Thanks for the reply.

    1. as a visitor go through your (sub)sites and visit some tags
    - I made all sites public and accessed some sites as a visitor. All blog tags were visible and working.

    2. add following lines to the "wp-config.php" file of your site:
    - I work for a school and our IT admin is out of town for a few weeks, so I won't be able to do this for some time since I don't have access to the server.

    3. run through entire theme/plugin conflict test again please as described on a flowchart in this article:
    - I did the following with no luck:
    1. Disabled all plugins
    2. Uninstalled Reader, Global Site Tags, and Post Indexer
    3. Reinstalled Post Indexer and then Reader (Trending Tags and Tag Search is still not working)
    4. Reinstalled Global Site Tags Widget (Still not working)

    I tested this on my personal site through GoDaddy on a fresh install of WP and trending sites won't show unless there is a post tagged somewhere on the network. In other words, Reader won't show an empty Trending Tags block. As soon as I posted with a tag, Reader and Global Site Tags picked it up. Everything works flawlessly there.

    Just to recap, the global site tags widget, Reader Trending Tags and Reader tags search are not working, but Global Site Search and Reader author and title search are working. I'll post the other information you requested as soon as I can.

    This support post details a similar issue.

    Thanks again for all of your help!

  • Adam Czajczyk

    Hello ict.bwya!

    Thank you for your response!

    Reader will not display "empty" trending tags box, indeed. After brief examination of your network though I was under impression that there are posts around that were posted with tags and that's why I asked you to also "click" on some tags (even though Reader doesn't count those visits).

    The point of repeating plugin/theme conflict test was to make WP produce debugging log so this test should be repeated after the debugging (see point #2) is enabled, otherwise it won't help - I'd like to track down the reason for the box not being displayed even though there are tagged posts already on the network and I hope that debug log may be of help here :slight_smile:

    Just to recap, the global site tags widget, Reader Trending Tags and Reader tags search are not working, but Global Site Search and Reader author and title search are working. I'll post the other information you requested as soon as I can.

    I'm pretty sure these are related so it would be important to solve the above issue.

    That being said, you mentioned that your IT admin is not available here and because of this you don't have access to the server. I'm guessing then that you wouldn't be able to provide me with FTP access credentials to your site as well? I'm asking this because if I was given an access I could just do all these test for you...

    Best regards,
    Adam

  • Dimitris

    Hey there ict.bwya,

    I hope you're doing really good today and don't mind skipping in! :slight_smile:

    Please find attached the debug log.

    Really appreciate sending us this debug file. It seems that there's couple of errors there and I think it's due to your theme. Did you manage to get any working condition during the theme/plugin conflict test?

    How can I contact you directly with the information for FTP access?

    You can send us your details through our contact form https://premium.wpmudev.org/contact/ using this template:

    Subject: "Attn: Dimitris"
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Also, please re-grant us with support access in your sites as it seems that the period expired. I kindly remind you our detailed information about this: https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.