Really slow website again

Once again my site is really slow. I need your expertise, please! Can you please help me set up minification and browser caching.

  • Dimitris

    Hey there Jay,

    hope you're doing good today!

    I just went ahead and initiated a Performance Report in HummingBird to see what improvements can be made here. Here's my findings:

    1) Improve server response time. As you can see there're some recommendations in place already.

    I can see that you've enabled the SG Optimizer plugin, but there are couple more steps that have to be done.
    a) that's a message on the top of all admin pages.

    SG Optimizer: Your site https://*************.co.uk is not cached! Make sure the Dynamic Cache is enabled in the SuperCacher tool in cPanel. Click here to hide this notice.

    so you have to activate it in cPanel too
    b) Memcached seems to be disabled here
    https://*************.co.uk/wp-admin/admin.php?page=caching

    The complete tutorial on SG cache solution can be found here:
    https://www.siteground.com/tutorials/supercacher/

    2) It seems that there's something conflicting with Browser Caching here
    https://*************.co.uk/wp-admin/admin.php?page=wphb-caching

    Could you please share .htaccess file of this installation?
    Simply download it to your local machine, rename it to htaccess.txt, remove any sensitive information like domain name etc. and attach it here in your next reply.

    Warm regards,
    Dimitris