Reauthentication of superuser.

Hello Ash ,
I upgraded to latest domain mapped plugin yesterday and now i can't log in to my superuser. I can log in to all the other "subdomains" if i go through their login page. But whenever i come back to example.com/wp-admin then it says...
http://example.com/wp-login.php?redirect_to=http%3A%2F%2Fexample.com%2Fwp-admin%2F&reauth=1&__domainmap_action=domainmap-logout-user and i can't access superadmin
I tried to remove all the plugins by renaming the folder to something else and the problem still persisted. I also changed the salt authentication.

  • Bojan Radonic

    Hey there @Eldin, hope you're well today!

    Sorry to hear you're having these issues :slight_frown: Is this happening when you're trying to login to your network or when logged in in one of your subsites and when going back to your network admin panel?

    If you're super admin acc is not working (you can't login) there is a trick that you can use to create new one by using php. Please check the following link:

    http://stephanis.info/2011/08/11/create-new-admin-account-in-wordpress-via-ftp/. This should create new admin account, to grant it super admin you'll have to add:

    grant_super_admin( $user_id );

    below the set role line.

    Please advise,
    Bojan

  • Voxxyz

    Hello Bojan, Thank you for your reply. This issue resolved itself while I was out for lunch... (ps i did change salt auth between every number(not that grateful from users but anyways...)
    The issue was only happening for the superusers... (we have 2 that both had the same issue) they could log in with their account on the subdomains.example.com/wp-admin but whenever they came to example.com/wp-admin it went into a reauth loop. This is what i did before lunch.
    1a. removed all caching
    1b . cleared C&C(Cookies&cache) in browser. (couldn't log in)
    2a. switched from nginx to apache
    2b.cleared C&C (couldn't log in)
    3a. checked htacces...

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    #RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    #RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    #RewriteRule ^(.*\.php)$ $1 [L]
    #RewriteRule . index.php [L]

    3b. Cleared C&C (couldn't log in)
    4a. switched back to nginx (restarted hhvm)
    4b. cleared C&C (couldn't log in)
    5a. restored all plugins back to normal
    5b. cleared C&C... couldn't log in
    6. lunch (1hr)
    6b. could log in....

    Did wordpress put some cookie somewhere inside wordpress? I am not that familiar on what happens under the hood on wordpress. but maybe you have more knowledge about this issue.
    Once again Bojan thank you for your quick reply.

  • Bojan Radonic

    Hey again @Eldin,

    Glad to hear everything is working now :slight_smile: I'm not really sure what the issue was exactly there. I'm assuming it was something related to cookies and possibly "Cross-domain autologin" option that could be found in Domain Mapping settings.

    If the issue is resolved now lets keep it as is and if it happens again please let us know so we can investigate this further :slight_smile:

    Have a great day!

    Cheers,
    Bojan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.