Received an error using the Bulk Smush feature of WP SmushPro Plugin

Hey Friend,

I received the error: "Error posting to API: 500 Internal Server Error" while using the "Bulk Smush" feature of the WP SmushPro Plugin. The images have stopped "Smushing" as well, and the progress bar appears to have stopped moving.

Can you help resolve this issue?

Talk soon,

Andrew Shwetzer

  • James Morris

    Hello Andrew,

    I hope you are well today.

    Usually, when you get a 500 Internal Server Error it's related to a plugin conflict. There's a couple troubleshooting steps I'd like you to try to see if we can narrow down the cause of this problem.

    First, could you please run a plugin conflict test as outlined in the following article? This will eliminate the possibility of a conflict with another plugin. https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If that does not lead to a solution, could you please enable WP_DEBUG and provide us with the output of your debug.log file?

    To enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    After you've visited the pages that are causing you problems, please go to wp-content/ on your server via FTP and download the debug.log file to your local computer. Then, rename that file to debug.txt and attach it to your reply here so we can examine it further.

    I look forward to seeing the results of your tests.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.