Recent Global Posts Feed URL returing a 404 error

Hello,
The feed url: http://blogs.duanemorris.com/feed/globalpostsfeed is returning a 404 error with this message:
"ERROR: This is not a valid feed."
I have the same plug-in installed on ercoats.wpengine.com and that feed url works fine. That url is: http://ercoats.wpengine.com/feed/globalpostsfeed
This breaking on blogs.duanemorris.com *seems* to have coincided with the upgrade of core WordPress to 4.7. However both installs were upgraded on 12/29/2016, so it doesn't really seem that the plug-in has a problem with 4.7.
Seems that it might be data on the blogs.duanemorris.com site. We have some pretty long post permalinks on this site... the one on the 1st post made after the last time I know the feed url worked is 192 characters long. This post also just happened to be the first post made after the upgrade to 4.7. Could the permalink length be an issue?
These are the steps I've taken, none of which have worked:
1. Reindexed the site (using the Post Indexer)
2. Deactivated the plug-in, then reactivated it.
3. Deleted the plug-in, then reinstalled it.
I am not seeing anything in the error logs that appear to be related to this. Nothing gets written to the error logs when I try to go to the feed url.
(There are errors related to the Recent Global Author Posts Feed plug-in, but that's a subject for a different support ticket, which I'll be entering shortly).
Any help in resolving this issue is greatly appreciated.
Thanks,
Denise Tucker