Recent Global Posts Plugin

I'm getting the following error when trying to install this plugin...

Warning: require_once(../wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/edetail/public_html/wp-content/plugins/recent-global-posts-feed/recent-global-posts-feed.php on line 28

Fatal error: require_once() [function.require]: Failed opening required '../wp-load.php' (include_path='.:disappointed:usr/lib/php:disappointed:usr/local/lib/php') in /home/edetail/public_html/wp-content/plugins/recent-global-posts-feed/recent-global-posts-feed.php on line 28

Any help would be greatly appreciated as this plugin is important to the site.