Recent Posts automatic upload conflict

Just a quick note that the recent posts plugin attempts to upgrade to a completely different plugin - quite annoying if you want to use the upgrade all feature. Would it be worth prefixing all plugins with WPMU to avoid these kind of conflicts?