Recently purchased and installed Membership. I marked a page as restricted to Visitors, yet they can

So i've recently purchased and installed Membership on my website and to test things out i added a page to the negative rules of a Visitor. (I also marked that anyone not logged in or without an account is seen as a Visitor).

When I log out and visit the page however, i can still see it. Also when i visit the page on a different computer altogether. Am i doing anything wrong here?

  • aecnu
    • WP Unicorn

    Greetings Joey,

    Thank you for your additional input, it is appreciated.

    Actually for the page you mentioned you should not be able to see it as a visitor without any rules.

    Membership is a bear to configure and must be mostly configured before it works correctly.

    In this case have you by any chance configured your URL groups?

    I think this is the main starting point for resolving your issue because you should not be setting negative Visitor rules, those URL's should be protected by default.

    Have you checked out and absorbed the Membership user manual by any chance?

    Please advise.

    Cheers, Joe

  • joey_van_ommen
    • WPMU DEV Initiate

    Hi Joe,

    I just removed the negative rules and added the URL of the page in question a new URL group. Unfortunately, upon refreshing the page, it is still clearly accesible to visitors.

    I have checked out the manual and thought i was doing i correctly, but that however doesn't seem to be the case.

    Cheers,

    Joey

  • aecnu
    • WP Unicorn

    Greetings Joey,

    Thank you for your additional feedback, it helps to figure out what is going on there of course :smiley:

    I would suggest trying a different browser on your computer for testing, one easy to clear the cookies and cache on and your favorite browser for development.

    Unfortunately, upon refreshing the page, it is still clearly accesible to visitors.

    If this is on the same browser you would get that effect because the site would recognize you as admin which can see all.

    Could you please post the hopefully protected URL?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Joey,

    Hilarious ... I use just the opposite, Firefox for developing and Chrome for testing.

    I have one more question before I may have to dive in there and check out what is going on in there, was this page you are trying to protect created before or after you had activated Membership?

    If before could you please try creating one now to see if it is indeed protected?

    Please advise.

    Cheers, Joe

  • joey_van_ommen
    • WPMU DEV Initiate

    Hey Joe, (where are you going with that gun in your hand? Couldn't resist),

    That page was indeed created before activating the plugin, but I just tested it with a new page i just created and unfortunately i can still very much acces the page. I also updated the URL group and added the link to the group.

    Thanks for your help so far, Joe.

    Joey

  • aecnu
    • WP Unicorn

    Greetings Joey,

    Thank you for the great reply :wink: and the testing!

    Actually my friends and family call me the same as I am addressing you now "Joey" and my wife calls me that only when she is mad at me ... lol ... at least I have a head up she is po'ed about something involving yours truly!

    It is now time to take a look i there and see if I can see what we are missing here.

    I am backed up in off forum request with three ahead of you right now but if you have a day or two to wait so I can dig in there.

    Please let me know and send your wp admin details to aecnu @ incsub.com and please include a copy of this tickets URL:
    https://premium.wpmudev.org/forums/topic/recently-purchased-and-installed-membership-i-marked-a-page-as-restricted-to-visitors-yet-they-can-still-view-the-page-whats-wrong

    Please advise.

    Cheers, Joe

  • joey_van_ommen
    • WPMU DEV Initiate

    Hey Joe(y),

    I know exactly what you mean as I am also only adressed as 'Joey' when my family is mad at me. It does give us a good indicator of what's going on, haha!

    Thank you for your help and you can expect an email from me with my details.

    Greetings,

    Joey

  • aecnu
    • WP Unicorn

    Greetings Joey,

    Thank you for your patience regarding this issue and my off forum arrival.

    I have indeed logged in tonight and you did not make me an admin in Membership.

    I cannot access the Membership settings, please add me as soon as possible and let me know.

    Another thing I found is that you had your permalinks set for default which is a big "Do Not Do" with plugins. So afterward I was going to go ahead and test the change but could not get into Membership.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Joey :smiley:

    Thank you for the follow up there but unfortunately I am still unable to see the Membership application and settings.

    You need to make me an admin by being logged into the admin dashboard go to --> Users --> find my test user name and then choose edit --> and then change the role to administrator.

    You can see who Membership administrators are by looking under Membership --> Options --> Membership Admins tab and I need to be showing in there.

    Please advise.

    Cheers, Joe

  • joey_van_ommen
    • WPMU DEV Initiate

    Hey Joey,

    That is very strange because you are an administrator! To double check, i checked again under users just now, and your role is set to administrator. Also, i looked under Membership Admins on the options page and your test user name also shows up there.

    What do you advice? Do I send you my administrator details?

    Joey

  • aecnu
    • WP Unicorn

    Greetings Joey,

    Wow the plot thickens, but maybe this works on my installation because the way I do it and the way I outlined it above is in error since I just did it again testing i.e. I go into All Members in Membership and chose any user, assign them as administrator and they automagically appear as a Membership administrator.

    Sorry but my bad in my earlier description.

    Please advise if this indeed does the job for us.

    Cheers, Joe

  • joey_van_ommen
    • WPMU DEV Initiate

    Hey Joey,

    I'm not entirely sure what to do at this point. I went back to All Members and you are still assigned as an Admin, both in Membersip and as a WP user.

    Can you check again? Or else i'll make a new account and try it over.

    Thanks, Joe.

    Joey

  • aecnu
    • WP Unicorn

    Greetings Joey,

    Thank you for the access and I believe you are now all set.

    The things I did were to first set your permalinks to /%postname%/ which they can be set to anything you want but not default.

    I finished configuring the --> Membership --> Options --> Content Protection page

    But that is not what made this finally work.

    What did is that when you dragged your URL Groups into the negative rules, you must check mark which group within the group and then click update.

    That did it and after logging out as admin and clearing my cookies I tested both your test pages and they came up as protected.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.