Recurring billing not functioning

A client of mine has been receiving emails from his subscribers telling him that they have have been billed twice for their subscription in the same cycle. Is this possible? If so how can we fix this.

We are using WordPress as the platform, up to date and authorize.net as the gateway.

Please let me know what we can do to solve this issue as soon as possible.

Thank you in advance!

-Jannette

  • Predrag Dubajic
    • Support

    Hey Jannette,

    Hope you’re well today.

    I did some research and found that some users had similar issues and the update to the plugin has been released regarding this, which version do you have installed on your clients site?

    Can you tell me if the users are billed twice at the same time or was there some time difference between the two?

    Is this happening only to new subscribers or at the recurring?

    Best regards,

    Predrag

  • Jannette
    • New Recruit

    Hello,

    We just updated it about a week ago, but I just noticed that there was an update recently. I had someone update the website about 5 minutes ago with the newest version.

    To answer your questions, the users were billed twice at the same time. One was labeled “captured” and the other was “recurring”. The website is pretty new, all of the users that have subscribed experienced the same thing.

    Do you believe that with the new update the issue will be resolved?

    Thank you,

    -Jannette

  • Predrag Dubajic
    • Support

    Hey Jannette,

    Sorry for the delay on this.

    I did some testing on my end and was unable to replicate the issue you are having.

    Would you mind allowing support access so I can have a closer look at this, I would like to test it with the sandbox account.

    If this is ok, just grant me temporary admin access to your site by clicking “Grant Access” button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hey Jannette,

    I’m not sure why you can’t give me access you should be able to have this option with your account. Can you make sure that your WPMU DEV Dashboard is installed correctly and you are logged in with your account?

    You can try disabling your other plugins to see if some of them is causing the issue.

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hey Jannette,

    We can try the other way by directly sending me your log in details.

    You can send us your details using our contact form and this template:

    Subject: “Attn: Predrag Dubajic

    -WordPress admin username

    -WordPress admin password

    -login url

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me :slight_smile:

    I will also check what is wrong with the dashboard plugin.

    Best regards,

    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.