Recurring fault

We had a ticket re slow admin that affected only the home page when editing it this was the reason we left hostgator and choose site ground to host only to find that this error came

Gateway Timeout
The gateway did not receive a timely response from the upstream server or application.

The problem is now it is happening on other pages I am copying this to site ground as I believe they and you have outstanding tickets on this one

Thanks John

  • Adam Czajczyk

    Hello John

    I hope you're well today!

    I believe you are referring to this ticket about "slow admin", right? I just want to make sure.

    As for the "Gateway Timeout. The gateway did not receive a timely response from the upstream server or application."

    That's usually caused by resource limits, when the site "exhausts" available memory, I/O, available webserver threads or database connection limits. However, I have visited your site - both back-end and front-end - but I didn't encounter that error.

    Is there anything specific I should do to trigger it or it's more "intermittent"/"random"?

    Since you have moved to SiteGround and you are using Hummingbird at the same time, there's one other important thing: please access cPanel and find SG Optimizer option there and inside you will find caching options. There should be static and dynamic cache and memcached - flush them all and disable them all to avoid conflicts with Hummingbird Page Cache, Asset Optimization and Asset Optimizatin internal caching.

    Kind regards,

  • John

    Adam thanks again for the help Site ground have checked it all out see below

    It happens when you first visit the front page to edit always you get the message after about 1.5 mins it started on some pages and posts today not everytime the message but now and then

    I don't want to drop the smart crawl as it is so useful on links etc

    They think cloud hosting is the answer however I am not convinced

    I suggested dropping other plugins again not a solution we know it is the plugin but what to do about it?

    I've checked your cPanel account and both Dynamic and Static caching were allredy disabled, so now both caches shouldn't interfere.

  • Adam Czajczyk

    Hi John

    Thank you for additional information!

    I'm really sorry but I still wasn't able to replicate it. As you may notice (if you take a look at "WPMU DEV -> Support" page in your site's back-end) I have accessed your site yesterday and today trying to "catch up" that issue but the site was working fine for me. I tried to edit homepage, update it, reload multiple times, visit as logged in user and as a visitor in another browser...

    I'm not sure if I'm still missing some step here or if I just "got lucky" (since the issue seem a bit "random"). Would you be able to record and share some screencast/video actually showing the issue while it happens? It would be great if I could see it, especially if you could include steps to "trigger" that on purpose. That might be very helpful!

    Kind regards,

  • John

    Adam there is not much to see let me take you through how this is happening I am using Google chrome

    In the word press dashboard I select edit front page and the page loads I scroll down select the bottom block from the theme and select a text and edit save on way out and close everything them hit the update and that is when we usually take 1 plus minutes and get the error on a blank white screen

    What became concerning I did new post

    It happened when saving and then updating to publish. If is is to be the plugin then I dont want right now to deactivate it as last time we lost all the meta data and links .

    The site ground guys just want me to upgrade to cloud hosting but it seems a silly thing if it is a setting in the plugin

    Looking back one of you guys insisted it was the sitemap loading causing things but I stripped the sitemap right back and all I can think of is it has to be the site crawl but what bit makes it happen?

    What browser are you using as if you dont have an issue one of the site ground people found that is worked for him and I did not think to ask what set up it may be if I can replicate your set up maybe I could try that and at least try and narrow it down

    Thanks for your efforts so far


  • John

    Adam Just got this error today 1.30 UK TIME

    500 - Internal Server Error
    This is a temporary server error.
    Please try to reload the webpage later.
    If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there.

    Common reasons for this error are:

    Incorrect file/directory permissions: Above 755.
    In order files to be processed by the webserver, their permissions have to be equal or below 755. You can update file permissions with a FTP client or through cPanel's File Manager.

    Incorrect Apache directives inside .htaccess file.
    Make sure you have not specified unsupported directives inside the local .htaccess file. Such include PHP settings and Apache module settings.

  • Adam Czajczyk

    Hi John

    Thanks for additional explanation, it actually did help and I was able to finally replicate this.

    I'm testing that with latest Chrome on Win but it's not related to browser or OS. I also highly doubt that any folder/file permissions are related to this.

    The .htaccess is also rather unlikely but it's worth checking. Could you share the current content of site's .htaccess file with me so I could take a look at that, please?

    There's also another thing that seems to be related. Currently the "max_execution_time" of your PHP instance seems to be set to "0" value which, in theory, means "no limit" but in fact on most shared hosting accounts it actually means the "maximum general/overall limit set on server by host". When the error shows up, you can see in a console that one of the crucial request that site's making, times out at slightly over 30 seconds. It might be a bit more or less in browser due to other resources still working/loading but in general it suggests that the "real" max_execution_time for PHP scripts would be most likely 30 seconds.

    If I remember correctly, SiteGround should let you change PHP configuration via cPanel. However, it's also possible that you already got some "tweaks" added to .htaccess file or you got a "php.ini" file in a root folder of your install.

    That said, if you can share .htaccess, I'll see if there are any related rules there. But please also:

    1) check if there's a "php.ini" file in a folder of your WP installation and if yes, look if there's any line that starts with



    2) look into your cPanel and see if there is an option to set PHP options (not just change PHP version or enable/disable modules but to set variables); that should give you a chance to set "max_execution_time" to something like 180 or even 300 seconds.

    Now, you may think that 300 seconds is long. It is, yes. But that not only affects that single script that times out - when the post is updated there are many request made and allowing them longer execution time will affect most of them; it doesn't necessarily mean slowing down the process but rather "giving it more space to use" :slight_smile:

    Let's start with that and see where it gets us :slight_smile:

    Best regards,

  • Adam Czajczyk

    Hi John

    Thanks, that might indeed make troubleshooting easier/faster :slight_smile:

    You can send all the credentials securely to me by:

    Note: Use our contact form and the template below:

    Subject: "Attn: Adam Czajczyk"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,

  • Adam Czajczyk

    Hi @info67688!

    First of all, I apologize for not getting back to you for that long. It's been a bit more busy here recently than it usually is, I believe that's partially due to the vacation season when some Members can use more time to take care of their sites and on the other hand some of our staff is also taking time to rest :slight_smile:

    Anyway, that's a good news that there's no server error now and thanks for letting me know. Still tho, 13 seconds is a loot so I'll focus on that.

    Once again, I'm sorry for keeping you waiting. I'll get in touch with you again via mail really soon.

    Kind regards,

  • Steve

    Hello all.. I ran a quick test on the site based on the url provided throughout and it seems like the likely cause of this is some fairly major optimization issues on the site.. So, more of a content related issue than a server related issue.


    Basically, the site has a 3mb home page (not terrible, but still maybe a bit large for a home page) but the big red flag is your home page itself has 244 requests.. That's 244 independent calls from the broswer to the server to the database before the page can ever load.
    This will cause a maxing out of server resources on nearly any "shared" hosting plan and will undoubtedly cause concurrent connection issues. You have tons of js/css scripts that make independent calls.
    I would recommend taking a full backup of everything and then trying something like hummingbird or autoptimize to minify/combine scripts and see how much that helps out.

    Like with anything its super easy to blame the hosting company or at least want to, but unfortunately a lot of this looks like it may be content related due to how its currently setup. Also, i'm sure at this point since you guys have been working on this for a bit I'm guessing a bit has been cleaned up but those issues still remain as of today.

    I hope that helps!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.