Redirect problem after login

With the Membership 2 plugin, after login, the redirect doesn’t work properly. Logged in members keep get redirected to the “Protected content” page, despite the settings set to go to the “Home 2×2” page. Website domain is Alessimusicstudios.ca

  • James Morris
    • WordPress Enthusiast

    Hello Burt,

    Just following up from our chat today…

    We resolved this in chat. The issue was that the login link used the www version of the domain URL whereas the actual url of the site is non-www. Once the link was changed to the non-www variation of the URL, everything worked correctly.

    To ensure that all traffic is properly redirected to your non-www version of your site, you should add the following code to your .htaccess file.

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^www.domain.com [NC]
    RewriteRule ^(.*)$ http://domain.com/$1 [L,R=301]
    </IfModule>

    Let us know if you have any further questions. We’ll be happy to help!

    Best regards,

    James Morris

  • AMS
    • Design Lord, Child of Thor

    Thanks James,

    There now seems to be a problem with Membership 2 connecting with PayPal. I remember you changed the setting with PayPal to test the previous issue. I am wondering if this has anything to do with the current problem. This is the email I just received form the content manager of the site:

    "this is a big one: a guy just signed up, a pro. Paypal money was there. He immediately writes saying he can't login. I reply just click on Home and you're good to go. That wasn't the problem, his account was listed as "Pending, activate

    on next payment" but he'd already paid. It was as if PayPal and the website aren't communicating. I tried everything to change his status to Active but it just wasn't happening. I'm really stumped. Screen shot attached.

    Any ideas?

  • Ash
    • WordPress Hacker

    Hello Burt

    It looks like the paypal redirect failed after payment. If you got the payment, you can manually mark the invoice as paid.

    Please go to Dashboard > Membership 2 > Billing > And click on the corresponding invoice number (not on view link) and then you can manually change the status. Please follow the screenshots:

    Hope it helps! Please feel free to ask more questions if you have any.

    Have a nice day!

    Cheers,

    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.