Redirection issue after activate the site.

I am using PayPal Sandbox for testing the payment. The issue is below:
>> User select a desired template
>> User redirected to checkout page with pricing tables
>> User select one of the paid plan
>> User fill-in site details: site name, email address, and etc
>> The message box tells the the site has been reserved, "Activate Your Site"
>> Click PayPal button
>> PayPal Sandbox website, enter test buyer username and password
>> Redirected back to same page on the main site with the old checkout pricing tables, activation message, and credit card form. <<<< It should have redirected user back to the dashboard or sth. else. This will definitely make user confused.

  • Adam Czajczyk

    Hello Cas,

    I hope you're well today and thank you for your question!

    I double checked it on my own site just to make sure and can confirm that this is working this way. That's not a bug but the default workflow of the plugin.

    After the redirection back to the page is done it should show a message stating that "Your site (here comes an URL of the new site) has been reserved but is not yet activated.

    Once payment has been processed your site will become active with your chosen plan. Your reservation only last for 48 hours upon which your site name will become available again."

    In order to minimize client's confusion you may want to make this message stand out from the rest of the page. This can be done with some minimal additional CSS styling:

    .reserved_msg h2 {
    /* custom rules for message title  */
    
    }
    .reserved_msg p {
    /* custom rules for message body */
    
    }

    That said, I agree that changing this behavior could be an important step forward in terms of User Experience/Usability so I'm moving this thread to our "Features and Feedback" forum and also marking it as a feature request.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.