Redirects attempting to get to network admin...

I have a major issue. I have had to do a pretty big rebuild following a hack. I have sort of got most things working (ish) but if I try to get to network admin or indeed a pile of other stuff following a snapshot reinstall of the base domain of the MU installation, I get a 'too many redirects' error. I though I had solved it but seemingly not. I have check the usual places and I am now baffled. Happy to grant you access where required. Hope you can help!

C

  • Michael Bissett

    Hey @Chris! :slight_smile:

    I'd be glad to have a closer look at things here, could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    On the contact form (linked to below), please select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Chris, my apologies for the delay here!

    I wasn't able to log in to WordPress the details you had sent my way, but in looking at your site via FTP, I noticed that the .htaccess rules presently have normal WordPress rewrite rules, instead of the subdomain .htaccess rules for Multisites created with WordPress 3.5 or later, as shown here:

    http://codex.wordpress.org/htaccess#WordPress_3.5_and_up

    However, in trying to change the .htaccess rules (I had to create a file of my own, as the one you had set up was protected), I found that they kept getting reset to the standard WordPress .htaccess rules (which also removed your PHP rule as well, causing a PHP version error).

    I tried disabling all of the plugins on your site, and leaving only the Twenty Thirteen theme available for access (disabling all others), all via FTP, but I still found the file to be reverted each time I tried logging in to WordPress.

    I'd want to check with your host about this, as there seems to be something deeper that seems to be restoring a backup of .htaccess, as it keeps getting recreated with this timestamp:

    8/18/2015 2:05:03 PM

    Either that, or if you can modify the .htaccess you have now, then it's unique permissions should keep it from being reverting to only having the base .htaccess rules.

    Once we can be assured that the .htaccess will stay modified, and that it includes the Multisite .htaccess rules, then we should be good to go here. :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.