Redirects on my /wp-admin page

I'm having an issue with some http:// and https:// redirect issues. I tested these redirects on https://next.httpstatus.io for my following admin site; https://armourmarketing.com/wp-admin and it's coming up with 3 redirects which I believe are causing my admin site to be SUPER SLOW. The frontend sites load fast. It's my /wp-admin that is superslow. I do not have any force SSL settings on (that I'm aware of). I'm also using Cloudflare.

  • Nithin

    Hi Matt

    Could notice issue, that's an odd redirect, seems like there are some rules in the .htacess regarding 301, or 302 redirects?

    If yes, could you please share the code in here, so I could have a better idea.

    If the https is only forced via cloudflare this is a really odd behaviour. Another cause would be that there are still http links defined inside the database which is getting loaded, to double check all your links are loading only in https, would recommend you to follow this article, and see whether there are any http links defined in any of the tables pointed in the article:
    https://wpengine.com/support/how-to-change-a-multi-site-primary-domain/

    Please make sure to take a backup before making any changes in the DB side. I hope that helps, please let us know how that goes, have a great day ahead. :slight_smile:

    Best Regards,
    Nithin

  • Matt

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    # RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    php_value max_input_vars 5000
    php_value upload_max_filesize 256M
    php_value post_max_size 256M
    php_value memory_limit 256M
    ## WP Defender - Prevent information disclosure ##
    <FilesMatch "\.(txt|md|exe|sh|bak|inc|pot|po|mo|log|sql)$">
    Order allow,deny
    Deny from all
    </FilesMatch>
    <Files robots.txt>
    Allow from all
    </Files>
    <Files robots.txt>
    Allow from all
    </Files>
    ## WP Defender - End ##
    ## WP Defender - Prevent information disclosure ##
    <FilesMatch "\.(txt|md|exe|sh|bak|inc|pot|po|mo|log|sql)$">
    Order allow,deny
    Deny from all
    </FilesMatch>
    <Files robots.txt>
    Allow from all
    </Files>
    <Files robots.txt>
    Allow from all
    </Files>
    ## WP Defender - End ##

    ## WP Defender - Prevent information disclosure ##
    <FilesMatch "\.(txt|md|exe|sh|bak|inc|pot|po|mo|log|sql)$">
    Order allow,deny
    Deny from all
    </FilesMatch>
    <Files robots.txt>
    Allow from all
    </Files>
    ## WP Defender - End ##

  • Ash

    Hello Matt

    I can think of following issues here:

    1. It could be because of any plugin which makes the redirect. So, would you please check after disabling all plugins and activating default theme?
    2. It could happen due to misconfiguration of cloudflare, so let's disable CF for a moment and check.
    3. And lastly it could be https configuration on the server side, if you don't use SSL from CF. Also, please check wp-config.php if there is any define which is related to SSL and/or admin.

    Let us know how it goes. Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.