Region vertical height does not apply

I have set the vh for all four container regions, but it does not apply. Can you have a look please.

    Adam Czajczyk

    Hello Pawusa Support,

    I hope you're well today and thank you for your question!

    I must admit I'm a bit confused. Could you please elaborate a bit on what exactly did you do (a simple "step by step" description would be great!) and what do you wish to achieve?

    It would help me investigate the issue and hopefully provide you with a simple solution.

    Please advise!
    Best regards,
    Adam

    Adam Czajczyk

    Hello Pawusa,

    Thank you for your response.

    I took a look at your site (both front- and back-end) and I can see that indeed the site doesn't adjust its height to the screen height. I'm still not sure how did you setup those heights but from what I can see your site currently consist of only three regions: header, "main" region and footer.

    The default way to set height of a region is to drag its edge up/down by the yellow bar/handle while in "Edit background" mode. This however will not "auto-adjust" it to screen height for various devices. Since such scenario is not that common it could be addressed with custom CSS. According to my tests with "in-browser" CSS changes these CSS rules should work for your site:

    .upfront-region-container-main-header {height:15vh;}
    .upfront-region-container-home-our-story {height:80vh;}
    .upfront-region-container-main-footer {height:5vh;}

    However, this will still need some additional adjustments and/or CSS rules for elements inside these regions. I think though you may want to give it a try first and see if it helps at least a bit.

    Best regards,
    Adam