Register and login pages are broken, unless I use 'virtual pages'

I've made a custom page for the courses signup on CoursePress Pro, and have of course put in the shortcode to add the form - [cp_pages page="student_signup"]

However I am finding the form does not submit, and just reloads the page. There's no errors in the console, and even with WP debug mode turned on there are no errors. The user is not created in WordPress, so it looks like the form isn't submitting at all. If I use a virtual page, it works fine.

I've tried disabling plugins so that the site only uses essential ones, and also I've tried activating the default CoursePress theme without my customisations - but the error is still there. The only thing I can think of that could be connected is we changed the site URL. Could there be a reference to the old URL breaking the forms somehow?

Many thanks

  • Predrag Dubajic

    Hey Darby,

    Thanks for granting access, I checked few things on your site and noticed that this issue is only happening on your current signup page, I created Test page with same shortcode, selected it as Signup page and was able to register from there.

    Can you try recreating the current page and see if it works after that, I wouldn't want to do this myself as I was unsure of how the styling was added and didn't want to remove your work :slight_smile:

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.