register shows wrong page

Hi, as a new user who wants to register I want the user to see my sign up page which shows three individual options. If I clik the menu button the sites shows correctly. But if I am not logged in and go to account it shows following site:
/register/?step=register
There is a registerform but no way to show the signup page. I need people to choose one of these packages and not to fill out a standard form.

How can the system link to the correct site with my three options?

thanks and kind regards R.

  • Denitsa
    • WordPress Warrior

    Hello FLYINGFOX,
    I hope you are having an amazing day!

    You can try setting your desired page for registration from the Membership 2 -> Settings -> General menu under Membership 2 Pages -> Registration. You can choose a different page and then view and edit it from the links just below the dropdown here. To have the registration appear in your menu you can enable Registration from under the Please select pages you want to appear in your Navigation.

    Let me know if this works for you!

    Warm regards,
    Denitsa

  • FLYINGFOX
    • Site Builder, Child of Zeus

    Hi Denitsa, that is exactly what I have done. I am using the standard register pager from wpmu membership plugin. So I need the shortcode to see the my packages and the register page is what I am using. I do not want to see the /?step=register.
    I have also a own navigation setup sighn up. The site behint is /register/ which works fine when you click the menu sign up. But if you click on account the /?step=register site comes up. This is what I need to change. May be this could be improved in an update. For me the /?step=register site makes not really sense. How can I change this without modifying the plugin-files?

    thanks and kind regards R.

  • FLYINGFOX
    • Site Builder, Child of Zeus

    I found the problem. I have to decativate the checkbox in wordpress appearance "everyone can subscribe". Than the page show the normal login. Now I need to figure out how to show a sign up button on protected content :slight_smile:

  • Sajid
    • DEV MAN’s Sidekick

    Hello FLYINGFOX,
    Hope you are doing good today :slight_smile:

    You can add any content including buttons, link and shortcodes in WordPress Dashboard -> Membership 2 -> Settings -> Protection Messages -> Shortcode protection message (see screenshot).

    I am assuming you are using shortcode for content protection. But you can do this same for any other method too.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.