"Register" text from registration button, header text not displaying

Hi - some setup details:

- XAMPP
- Localhost
- Sub domain config (versus sub folder/blog)
- Allow new users to register enabled

The problems I'm having:
(1) Header - in the header preview, it shows the name of my site; however, when viewing the site, no header text is displayed (not a huge deal as I want to replace with an image anyway, but I offer that as perhaps an indicator of the second (and potentially other) issues below:
(2) Register button text not displayed - the registration button is visible (unexpanded). There is not text for "registration" or "join or community." If I click the button, I do get the registration form, but the actual text to "register: is not displaying ..

please advise ...

  • Tammie
    • WordPress Wizard

    @pabloroboto: What is your installation path... do you have under themes/

    bp-daily
    bp-daily-child

    If you have anything else apart from that it could be your issue. I am almost 100% sure it's something to do with your installation. These are some great documents to help you diagnose issues, unfortunately it's a little harder as you I take it can't provide a link to see this as only local?

    https://premium.wpmudev.org/wpmu-and-buddypress-themes/helpsheets/

  • Tammie
    • WordPress Wizard

    @pabloroboto: What version of WordPress and / or Multisite are you using - this theme works on 3.0? There must be something going on where you're not saving the theme options as those all are to do with that. Can you make sure you have no plugins on apart from BuddyPress and test again please. Also please make sure you're on the latest version of Daily.

  • pabloroboto
    • Design Lord, Child of Thor

    okay -- verified/ re-installed the following

    WP 3.0 (multi-user not enabled in wp-config.php)
    BuddyPress 1.2.5.2
    Daily 3.3

    I did the following:
    - Added categories, changed title of site
    - Changed wp-config.php to have the right connection details
    - Changed hosts file to have the localhost.dummydomain I wanted

    Results:
    - Header image problem still there
    - Register link still not showing up
    - Categories not showing up

    Still having all the same problems.

    Maybe has something to do with XAMPP

    yours truly,
    poorNoob .. (aka pabloroboto)

  • Tammie
    • WordPress Wizard

    @pabloroboto: I've asked some other people about it incase it is XAMPP as I've not got a lot of experience on that. Just one idea what happens if you do not do this:

    - Changed hosts file to have the localhost.dummydomain I wanted

    Just incase that is being done wrongly.

  • pabloroboto
    • Design Lord, Child of Thor

    So, i've changed that a couple of times and its worked fine in terms of redirecting to the local install of buddypress/wordpress mu. I don't think that's the issue, but I will try removing the hosts file reference to the dummy domain .. though I'm pretty sure its necessary with XAMPP as localhost otherwise would point to XAMPP install ..

    I also may just start completely over with a fresh install of XAMPP, etc ... and see what happens. Unfortunately, all I have really are weekends to try to troubleshoot ..

  • pabloroboto
    • Design Lord, Child of Thor

    Tammie -- got this figured out.

    3 main things ...

    1. I upgraded to Daily 3.4
    2. I did not try to troubleshoot XAMPP any longer, but uploaded to my host
    3. Ahem, and I believe this is the main one (along with 1) ..

    I added some register text and the register text button :slight_smile: in Theme Options > Spotlight settings.. which was likely the problem all along. It was blank. Sorry .. little attention to detail next time on my part ...

    thanks for your help. Ejoying the theme thus far.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.