Registered members are not added to membership

I am trying to set up a FREE access level for users to just have a free account to access no public information and also a paid access level.
But when you try to create the FREE signup it takes you back to the create an account screen, no confirmation that you have done anything at all and you never get an activation email.
When you try to do the paid version of the signup it never even takes you to the pay screen you go back to the signup form. Either way, it appears you did nothing on the user end. When you look at the users it shows the signup or account creation but doesn’t even show the level they signed up for.

With the regular WP signup it says - account created activate check your email etc... Nothing with the membership plugin.

Both the paid and free signup do the same thing. Takes you back to the signup form like nothing happens. On the wp-admin screen, the account does show up. But to the user, it appears nothing happened. An activate email or notice never appears and also on the paid version of the signup there isn’t a pay screen and yes PayPal is setup and activated.

I tried to deactivate all plugins and leave only Membership 2 Pro and the WPMU DEV Dashboard activated and in this case member were able to sign up, but they were not receiving the confirmation email after signing up (only admin was receiving the confirmation email).

  • Predrag Dubajic

    Hi John,

    Hope you're doing well :slight_smile:

    I just registered two accounts on your site and both were registered without any issues, I got the confirmation notification on your site and after that I could access my account page right away.

    Can you tell me if this is still happening to you and if yes can you tell me which browser and OS you are using so I could test in same conditions.

    As for the free account emails, those emails are part of the Additional Automated Emails add-on which I now enabled for you so you can go to Membership 2 > Settings > Automated Emails and configure "Subscription - Completed (Free membership)" email.
    Second account was created when this email was enabled and I got the email as well but I've disabled it now so make sure to enable it once you add your desired content in that email.

    Best regards,
    Predrag

  • John

    Hello,

    After slowly re-enabling all plugins I found that the plugin the caused the issue initially was the "Google recaptcha plugin" when this plugin was activated again the signup process was once again broken as described. Also I have the send email to free account option enabled and during testing I have created a couple dozen account and have only received an email confirmation on the client side once out of all the test signups?

  • Predrag Dubajic

    Hi John,

    I just test Google Captcha on my installation and it worked fine there, is this the one that you are referring to: https://wordpress.org/plugins/google-captcha/

    Can you try on your end with Google Captcha enabled but with default WP theme and see how it works then?

    Also I have the send email to free account option enabled and during testing I have created a couple dozen account and have only received an email confirmation on the client side once out of all the test signups?

    That's strange, same functionality is used each time so there shouldn't be anything in Membership 2 plugin that would send emails one time but then stop...
    Can you tell me if you are receiving all the emails when you create multiple users in a row from backend?
    Have you checked your Spam/Junk folder and made sure that emails didn't end up there?

    Also, have you tried using some SMTP plugin like this one https://wordpress.org/plugins/easy-wp-smtp/ so that your emails are sent that way?

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi John,

    This one: Google Captcha (reCAPTCHA) by BestWebSoft

    This plugin is not fully tested with Membership 2 but I gave it a quick test and couldn't replicate the issue on my installation.

    Can you try with default WP theme, as mentioned above, so we can see if there's some issue with your theme and these two plugins?

    As for the emails they eventually came but was severely delayed?

    This might be best discussed with your host and see if they can find anything in their longs on why the emails are delayed, or try using SMTP plugin.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.