Registering not working on membership plugin

Hi there, I spotted that someone else on the forum also got the message "Sorry, your signup request has failed. Try again." And I left a comment, but I'm not sure it is exactly the same problem. When testing and creating an account http://www.heypresto.com/register-2
I usually use my own membership buttons but, as this was not working, I just added the standard shortcode - both give the same message - with the person signing in only becoming a member of the site and NOT a member of the Membership plugin.
Obviously not being able to register is a big deal, and not too sure where to start looking for the problem.
All the best,
Justin.

  • Ivan Shulev
    • The Bug Hunter

    Hey Justin ,

    I hope you are having a nice day so far!

    In order to investigate further, I would kindly ask you to enable WordPress debugging (https://codex.wordpress.org/Debugging_in_WordPress) by adding the following code in your wp-config.php file, right before the line that says "/* That's all, stop editing! Happy blogging. */":

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    This will output all debug messages in a file called debug.log, located in your wp-content folder.

    I believe we will have to do some debugging on site so I will ask you to backup your website (https://premium.wpmudev.org/project/snapshot/ is a good tool for the job) and send us FTP login credentials.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic.

    Send in:

    Subject: "Attn: Ivan Shulev"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    I assume the issue is occurring for the free membership as well? Or is it only for the payed ones?

    If there is any specific way of reproducing the error, please mention it.

    Thank you and I am awaiting your reply!

    Ivan

  • Justin
    • Design Lord, Child of Thor

    OK I have added the code as described above in FTP.
    I've allowed support access on the site and I've just sent you a message with the FTP details on :slight_smile:
    I have had a few people try to log on (the free membership) but they get an error message. I have tried also (using OSX) and I get the message and the site gets confused about what sort of membership you have.
    Hope this helps - any questions - let me know :wink:

  • Ash
    • WordPress Hacker

    Hello @BigFresh

    I hope you are doing good.

    Please create three lists in Mailchimp and use those three separate lists in M2 > Settings > Mailchimp. It seems there is some logical issues when same list is used for three options. I am marking as bug for now, but please do the above as a quick workaround.

    Have an awesome day!

    Cheers
    Ash

  • Vaughan
    • Support/SLS MockingJay

    Justin

    The advice from Ash above should work for you too.

    Go to your mailchimp account & create another list for members.

    Then in your M2P mailchimp settings, select this new list for the members list in the dropdown. So you aren't using the same list for non-members & members.

    Dashboard > membership > settings > mailchimp

    Hopefully that should fix the issue for you.

    Cheers

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.