Remove demand for content to be served over https

I have multiple errors, as shown below. I have been unable to find themes.googleusercontent.com to fix it. Is there a way around this - perhaps allowing this specific url to not have to be loaded over SSL? How would I do that? or is there another way? Support access is granted.

VM53:16 Mixed Content: The page at 'https://christiangays.com/' was loaded over HTTPS, but requested an insecure font 'http://themes.googleusercontent.com/static/fonts/opensans/v8/DXI1ORHCpsQm3Vp6mXoaTXhCUOGz7vYGh680lGh-uXM.woff'. This request has been blocked; the content must be served over HTTPS.d @ VM53:16

VM53:16 Mixed Content: The page at 'https://christiangays.com/' was loaded over HTTPS, but requested an insecure font 'http://themes.googleusercontent.com/static/fonts/opensans/v8/cJZKeOuBrn4kERxqtaUH3T8E0i7KZn-EPnyo3HZu7kw.woff'. This request has been blocked; the content must be served over HTTPS.d @ VM53:16

VM53:16 Mixed Content: The page at 'https://christiangays.com/' was loaded over HTTPS, but requested an insecure font 'http://themes.googleusercontent.com/static/fonts/opensans/v8/MTP_ySUJH_bn48VBG8sNSnhCUOGz7vYGh680lGh-uXM.woff'. This request has been blocked; the content must be served over HTTPS.

Mixed Content: The page at 'https://christiangays.com/' was loaded over HTTPS, but requested an insecure font 'http://themes.googleusercontent.com/static/fonts/opensans/v8/DXI1ORHCpsQm3Vp6mXoaTXhCUOGz7vYGh680lGh-uXM.woff'. This request has been blocked; the content must be served over HTTPS.

VM53:1 Mixed Content: The page at 'https://christiangays.com/' was loaded over HTTPS, but requested an insecure font 'http://themes.googleusercontent.com/static/fonts/opensans/v8/cJZKeOuBrn4kERxqtaUH3T8E0i7KZn-EPnyo3HZu7kw.woff'. This request has been blocked; the content must be served over HTTPS.

VM53:1 Mixed Content: The page at 'https://christiangays.com/' was loaded over HTTPS, but requested an insecure font 'http://themes.googleusercontent.com/static/fonts/opensans/v8/MTP_ySUJH_bn48VBG8sNSnhCUOGz7vYGh680lGh-uXM.woff'. This request has been blocked; the content must be served over HTTPS.

  • Adam Czajczyk
    • Support Gorilla

    Hello Mary,

    I hope you're having a nice day!

    You site is set to be running over secure HTTPS connection. There's no option to allow some resources to be fetched/delivered over insecure "HTTP" connection without breaking the SSL security rules. Such an attempt would be either blocked by the user browser or will cause a message that some part of the site is "insecure". The latter may cause user to abandon the site or even trigger a block from the antivirus software, a firewall etc.

    In my opinion, it would be much better to find the place where these fonts are included to the site and make sure that they are loaded over "https://" connection. I checked that and the are available via both "http://" and "https://" so this is one step forward. The second step would be to find how they are included to your site.

    This usually is done via the theme, unless you are using some kind of plugin to do this. However, I visited the site in question and checked browser console and I didn't see any of these errors. I noticed some fonts loaded properly over HTTPS but none over HTTP and no error messages such as those that you mention.

    That makes me a bit confused. Do I miss something? Did you make some changes after you posted this post?

    Please advise!
    Best regards,
    Adam

  • Mary
    • Wisp of the WP Loop

    Hi Adam,

    This is an issue I've been battling for months and have not been able to find a resolution. I have a very good relationship with the author of the theme and he assures me that his coding is all good. In fact I have checked it and he uses // instead of http or https, so I don't believe it's in the theme.

    Also, I tried it with theme twenty-sixteen and I get the same errors.

    I have just done ANOTHER clean install of WP and I only have the most basic of plugins installed.

  • Dimitris
    • Support Star

    Hey there Mary,

    hope you're having a beautiful day! :slight_smile:

    I just went ahead and inspected your website and noticed that you're using the GeneratePress theme.

    Is this the theme previously used which gave you troubles with these non-secure links?

    I also was unable to spot any errors in dev tools now. :thinking:
    Could you please elaborate a bit more on this so we could further assist you?
    Please advise!

    Warm regards,
    Dimitris

  • Mary
    • Wisp of the WP Loop

    Hello Dimitris,

    Yes you are correct. I am using GeneratePress theme and yes, it has always given me those non-secure links, however I also switched to Twenty Sixteen theme and I get exactly the same errors.

    There isn't much detail to give you. If you go to the website and click on Javascript Console you will see the errors.

  • Mary
    • Wisp of the WP Loop

    Status update: In an attempt to get rid of these errors I have deleted my whole website and am doing a clean install. Please note in first screenshot that there is NOTHING in my website and yet I still have the error that the page is trying to load insecure content (fonts).

    In the process of trying to find out more about this error I notice that on the Chrome support page they have the same warning. See second screenshot.

    This is extremely frustrating because as along as I have an error I don't know how it is affecting my website.

  • Mary
    • Wisp of the WP Loop

    Status update: I have done a clean reinstall and I have NOTHING on the website except the basic WP files. I am using Twenty Sixteen theme with NO PLUGINS.

    I decided to find out where this mixed content message is emanating from by removing all parts of the page, one by one. I removed site identification and tagline. Next I removed all widgets and footer with copyright. I then removed title and content of page.

    My page is blank white - nothing on it, and yet I have three mixed content errors, all requesting content 'http://themes.googleusercontent.com/static/fonts/opensans/v8/

    I have noticed that this error also appears on many of my other sites as well, although not all.

  • Jaxom
    • Dragon Rider

    Hi Mary
    That is really odd, if your having the same issue on other sites I would ask your host.
    I know for a fact that Twenty-Sixteen uses https://fonts.googleapis.com/css/
    Mary I have just had a look at your site and run an audit. I get a clean load with secure HTTPS and no errors displayed. I would talk to your hosting provider one about this issue as I can find no call or hook to http://themes.googleusercontent.com. I would also ask them why Gzip is not enabled, Gzip allows your website to be served in zipped format and unpacked when it arrives on the local machine, this has a very positive outcome to your loading speed. There are a couple of other issues but they can wait.

    David

    • Jaxom
      • Dragon Rider

      Hi Mary
      Without seeing your server error logs I wouldn't like to guess. I just had another look at your site and I can't see where it is picking it up from.
      If you have FTP access there should be an error log in the public html folder which would give a starting point as to what is causing it.

      David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.