Remove Events & Featured image

Hi,

1) Is there a way to hide the Events tab from a buddypress member profile so that only the logged in user can access it ?

2) Can I remove the add featured image from the front editor form add events in user profile under events tab ?

Thanks

  • John

    Hi ,
    Still have some issues ,
    1) if I add :
    #eab-events-fpe-meta_info .eab-events-fpe-col_wrapper:nth-child(4) {display: none;} to custom css, then on the add event front page editor the ability to publish is not displayed either.
    If I leave the css as is , and add details for an event when i click publish nothing happens .

    2) when I try to add media from a url or media library and select insert into post - nothing happens, If I try to add from my computer it works fine.

    3) When logged in as a user with the ability to add an event , in the front page editor when I click to change the featured image the pop up shows the hompage instead. I cannot publish an event either from the add event page or from within the events tab on a buddypress profile.

  • Nithin

    Hi John,

    Hope you are doing good today. :slight_smile:

    Can you tell me or point me in some direction as to how I would add a event description / details area under the Venue text area in the add event front page form , as a multi line text field ?

    This is odd, by default a visual editor should be present, along with the add media button to add event description. Could you please switch to a default WordPress theme, and check whether it works?

    1) if I add :
    #eab-events-fpe-meta_info .eab-events-fpe-col_wrapper:nth-child(4) {display: none;} to custom css, then on the add event front page editor the ability to publish is not displayed either.
    If I leave the css as is , and add details for an event when i click publish nothing happens .

    Please try the following CSS, and check whether it works fine:

    #eab-events-fpe-meta_info > div:nth-child(4) > div.eab-events-fpe-col_wrapper {
      display: none;
    }

    I could notice that clicking the publish button doesn't seem to work, this seems to be an issue related to your theme. Please switch to a default theme, and see how that goes. I could see you are working on your site at the moment, so I didn't switch themes to test this. However, I can confirm it works fine in my default WordPress theme.

    2) when I try to add media from a url or media library and select insert into post - nothing happens, If I try to add from my computer it works fine.

    I'm not able to replicate this in my test system. Could you please check whether it works in your default theme, if yes, this issue is more related to your premium theme.

    3) When logged in as a user with the ability to add an event , in the front page editor when I click to change the featured image the pop up shows the hompage instead. I cannot publish an event either from the add event page or from within the events tab on a buddypress profile.

    I wasn't able to replicate the popup showing homepage in your site. It seems to work fine, however the publish button doesn't work.

    Please switch to your parent theme, and check whether the issue is related to your child theme. If you still find that the issue is related to your premium theme, would recommend you to get in touch with your themes support in order to get this sorted faster.
    https://www.gavick.com/forums

    If you aren't able to make this work in a default WordPress theme, then this would be more of a plugin conflict, please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    I hope this helps. Please let us know how that goes, so that we could give a closer look. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.