Remove pop up text from same page the drop downs appear

Hi - as Mattg1 was my developer, and now I'm managing the site, I have made an error with the coding that I can't identify , even using "browse previous versions"

this text

"Comprehensive New Patient – 75-90 minutes
Full history is taken in this time- The whole body system is assessed to evaluate the underlying cause for your problem, and analysed according to Chinese medicine theory. The tongue and pulse and sometimes the abdomen are examined in addition to a series of questions about your lifestyle and general health. The booked session time is 90 minutes. Regular time is 75 mins $130. If we use the full 90 mins the fee is $160. If you want herbal medicine, the herb cost is additional to the consultation price, while acupuncture is included in the set price.

Acute New Patients – 60 minutes
Acute pain in new clients can be treated in this time with acupuncture. $105. This avoids the need for a comprehensive assessment. ( IF you want a neurological or muskulo skeletal evaluation or herbal assessment, this is NOT the correct appointment for you. You need a Comprehensive New Client appointment instead).

Standard Review (Herbal Medicine and/or Acupuncture) – 45-60 minutes
If your herbs or acupuncture plan needs tweaking , or you like to really relax and take your time – this is the assessment & treatment time we need. Includes acupuncture treatment &/or herbal dispensing. $80. Herbs charged separately, cost extra.

Short Acupuncture– 30 minutes
Only suitable for pre-designed acupuncture points to be applied $55, or treatment of children $50. (Herbs can be reviewed in this time, but dispensing services after you leave attract higher fees as it still takes on average another 30 minutes to design, dispense and document herbs to be collected later)."

The above used to be only visible when the popup/drop down was selected. After rearranging the services order, I lost the ability to hide the above text from the appointment page. How can I hide again, except to only view when click on service item?

AND despite the services being denoted bold in the scripting, , the pop up text is pale grey and the drop down arrow is pale grey.. I can't see how to change how they display to choose more obvious colours/ bold black. Attached is the page as it appears now . Too much scrolling down- hence I need to hide the redundant text please

  • Nithin

    Hi Shelley Beer,

    Hope you are doing good today. :slight_smile:

    The above used to be only visible when the popup/drop down was selected. After rearranging the services order, I lost the ability to hide the above text from the appointment page. How can I hide again, except to only view when click on service item?

    I have having difficulty in accessing your dashboard, the page keeps on loading for me. And this is what I see, when I access the Appointments settings page:

    Since you did mention that you did an error while coding, could we know, where did you try to edit?, is it in a theme, or in appointments+ plugin, so that we could have an idea whether it's related to your code changes, or not. Is it possible to revert to the previous version of your plugin?

    Could you please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    I can't see how to change how they display to choose more obvious colours/ bold black. Attached is the page as it appears now

    If I'm not mistaken, there isn't any popup feature in the plugin, either it's customised, or the popup is part of another plugin, that you are making use of.

    And if you meant this arrow, as show in the above screenshot, it an image which is part of your theme, you'll have to check whether you theme provides, any other new styles. If not, you'll have to add a new edited image which is according to your color.

    I hope this helps. Please let us know if you need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Shelley Beer

    Nithin, thank you for your replies.

    I clicked the link you provided and put the search string "plugin/theme conflict test" into the find window.... nothing found ( Screenshot attached)

    You are correct- the pop ups are a separate scripting added to my webpage - so it seems I have to wait for my developer to become available again.. I'll see if I can improve the themes- in fact, godaddy advised I needed to

    Remove query strings from static resources
    Optimize the order of styles and scripts

    IS styles and scripts the same as themes?
    Are there any static resources in my appointment app?

  • Shelley Beer

    I overlooked responding to WHERE did I change the script

    it was between these lines - I already advised I have tried to identify when I accidentally cut some text between the popup series and the the plain text - but browsing all the revisions back 2 months I cant see where this is.. I was hoping yu might know what I needed to reinsert to separate the popup script from the "regular text" ( All the appears below </div> </div>
    -----------------------
    <div id="popup4">
    <h3>
    <h3>Short Acupuncture- 30 minutes</h3>
    Only suitable for pre-designed acupuncture points to be applied $55, or treatment of children $50.   (Herbs can be reviewed in this time, but dispensing services after you leave attract higher fees as it still takes on average another 30 minutes to design, dispense and document herbs to be collected later).
    </div>
    </div>

    <p style="text-align: left;"><span style="color: #0000ff;">
    Community Acupuncture- Daylesford Centre only</span> -  Booked
    appointments are next in the queue. Casual  "drop in" is still available .</p>
    <script id="setmore_script" type="text/javascript" src="https://my.setmore.com/js/iframe/setmore_iframe.js"></script><img border="none" src="https://my.setmore.com/images/bookappt/SetMore-book-button.png" alt="Book an appointment using SetMore" />
    ----------------------------------------------------------------------
    This scripting corresponds to the current view I have copied below

    Short Acupuncture- 30 minutes

    Only suitable for pre-designed acupuncture points to be applied $55, or treatment of children $50. (Herbs can be reviewed in this time, but dispensing services after you leave attract higher fees as it still takes on average another 30 minutes to design, dispense and document herbs to be collected later).

    Community Acupuncture- Daylesford Centre only - Booked appointments are next in the queue. Casual "drop in" is still available .

    Book an appointment using SetMore ( Button)

    Book via this button- a white square will load , please wait . Please note- the bookings close 12 hours before the session starts, so it does not mean there's no time when it says "NO TIME SLOTS". It just means bookings have closed for that session. You can still join the drop in queue. Do come !

  • Kasia Swiderska

    Hello Shelley,

    Can you again grant support access so we could check your appointment page? It looks like access expired so we are not able to get there.

    I clicked the link you provided and put the search string "plugin/theme conflict test" into the find window.... nothing found ( Screenshot attached)

    Please click this link https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/ and scroll down till you see image with flow chart , there is no need to use search box

    IS styles and scripts the same as themes?

    Styles and scripts are part of themes and plugins. Its not the same.

    Are there any static resources in my appointment app?

    Static resource refers to one that is not generated with code on the fly, meaning that its contents won't change from request to request. Images, JavaScript, CSS, etc., are all candidates for this. However! Appointment page is not page that should be treated as static resource at all and should not be cached. It has to provide always updated view of free/booked slots for your visitors, so they will see what they can and what cannot be book.

    kind regards,
    Kasia

  • Shelley Beer

    Kasia

    I have worked though the flow chart- it was was quite nerve wracking seeing my site disappear- and as I turned each plug in back one ONE at a time, with no reproduction of the site crashing- the first app restored my home page, but no one app restored my site until I decided to stop selecting the plug ins to activate. I left the YITH WooCommerce Wishlist and YITH WooCommerce Zoom Magnifier not reactivated as I am sure idid not have Woo commerce activated before. SO finally I selected the " activate installed plugins" menu link. and my site was restored .. Could you comment what caused this fatal error message ? It is all working now . And how is the " activate installed plugins different to manually selection plug ins? That was the only action that recovered my site after testing for removing appointments crashing the site

  • Shelley Beer

    Kasia

    I have worked though the flow chart- it was was quite nerve wracking seeing my site disappear- and as I turned each plug in back one ONE at a time, with no reproduction of the site crashing- the first app restored my home page, but no one app restored my site until I decided to stop selecting the plug ins to activate. I left the YITH WooCommerce Wishlist and YITH WooCommerce Zoom Magnifier not reactivated as I am sure idid not have Woo commerce activated before. SO finally I selected the " activate installed plugins" menu link. and my site was restored .. Could you comment what caused this fatal error message ? It is all working now . And how is the " activate installed plugins different to manually selection plug ins? That was the only action that recovered my site after testing for removing appointments crashing the site

  • Shelley Beer

    Oh dear , this seems to have crossed over - this thread is meant to be about scripting, not site giving 404 & 504 errors- crashing - going off line while editing appointments. Anyway it seems to be stable now. So the focus is meant to be how to remove the repeated text on the the page with "pop ups" - my appointment page - the text in the service boxes- pop up/ dropdown is not meant to be repeated on the page below the appointment grid

  • Kasia Swiderska

    Hello Shelley,

    I'm having real trouble to edit appointment page in your website. I'm trying and each time it load and load and never revel content for me to check. Do you see same issue when you edit pages?
    Last time there was issue with settings in Appointments - but now they work fine, but I cannot edit pages at all.

    As for plugin conflict. Your theme has inside functions from plugins included in quite "ugly" way. it means that it will break when some plugins are not activate because there is no check if those functions are available at the moment.

    And how is the " activate installed plugins different to manually selection plug ins? That was the only action that recovered my site after testing for removing appointments crashing the site

    Some themes have this feature build where they recommend or require specific plugins to work correctly, so they have those notification with links to activate required plugins.

    So in case of your site plugin conflict would need to be combined with theme conflict test, because your theme will break without plugins.

    kind regards,
    Kasia

  • Nithin

    Hi Shelley Beer,

    Hope you are doing good today. :slight_smile:

    I'm getting the same result as what Kasia mentioned, I'm finding it difficult the edit your pages, since the page contents are not loading.

    There seems to be a conflict, either it's coming from the the customised Appointments+ plugins, or maybe from some other plugin. I tried to switch to a default theme still the same for me. Do you have a version of Appointments+ to which you can revert to? Is the website live? Could I perform a plugin conflict test, so that we could rule out whether any other plugin is causing this issue.

    Would recommend you to test with a default theme, and then perform a plugin conflict test, please let us know how your conflict test goes, so that we could give a closer look. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Shelley Beer

    Nithin you are so kind to make these suggestions

    Your screen shot shows you have not selected the tab with the code. The visual tab will not show anything until you select the text tab first . Find attached sequence of screen shots showing this.
    The Site is live
    I can edit it
    I turned off all the plugins and one by one tested them. The site did not break at any stage of testing. I did this without making any adjustment to the themes. Did I make a mistake in turning them all back on? I just left out YITH WooCommerce Wishlist and YITH WooCommerce Zoom Magnifier not reactivated as I am sure i did not have Woo commerce activated before.
    I don't have a previous version of appointment+ app

    I have tried to load the site tonight via IOS phone- i got unfamiliar imagery- instead of my theme it was headed "spalab" subtitled "a beauty theme" , and the error message read "The jQuery library must be included before the smooth scroll.js file . The plugin will not work properly"

    When I selected appointments the incorrect image of that page loaded with the substituted logo, I could select the service type, but there was no functionality after that . Now I have gone back on line tonight and I see that my own logo has been replaced by "SpaLab" etc.. I have done nothing to do this. See far left header - vs what it should look like ( 2 more screen shots). However I can make an appointment on line without this error message I got using the phone

    I am in clinic tomorrow, so would be very pleased if you could perform a plugin conflict test, so that we could rule out whether any other plugin is causing this issue. Especially if your time zone is active while I'm asleep - no one is likely to be using my site tonight , now after 10.30 pmAEST

  • Nithin

    Hi Shelley Beer,

    I checked your website, and performed a plugin conflict test, and it's really odd, but I'm still having issues, I tried to create a new post, and I'm getting a 408 Request Time out. I'm still having issues editing your pages, and I already did try the text mode, and visual mode, but the the browser just keeping on loading.

    There is a mu-plugins named system plugin, this might be causing a conflict, as plugin conflict didn't make much difference.

    Since your current appointments page is heavily customised, and it's pretty tough to determine what's the issue, as the page is still not loading for me. Could you please try creating a new page, and add the following in your default text editor:

    <table>
    <tbody>
    <tr>
    <td colspan="2">[app_my_appointments]</td>
    </tr>
    <tr>
    <td>[app_services]</td>
    <td>[app_service_providers]</td>
    </tr>
    <tr>
    <td colspan="2">[app_monthly_schedule]</td>
    </tr>
    <tr>
    <td colspan="2">[app_pagination month="1"]</td>
    </tr>
    <tr>
    <td colspan="2">[app_login]</td>
    </tr>
    <tr>
    <td colspan="2">[app_confirmation]</td>
    </tr>
    <tr>
    <td colspan="2">[app_paypal]</td>
    </tr>
    </tbody>
    </table>

    If you set your description page, under Appointments > Settings > Service, the new page should show these description when your select the services, that's the default plugin behaviour.

    I hope this helps. Please let us know how that goes.

    Kind Regards,
    Nithin

  • Nithin

    Hi Shelley Beer,

    Hope you are doing good today. :slight_smile:

    what is a mu-plug in? a mu-plugins named system plugin

    Mu plugins, are must use plugins which are automatically enabled in your system, there is a plugin named system plugin, I'm not sure what it does. If you rename the /mu-plugins folder under /wp-content/mu-plugins, the plugin will get disabled, you can hence check whether it's causing any conflict.

    When I try to create a new page, I have noticed the visual editor doesn't load, once you click the text editor, and then click the visual editor the content appears, this is not how the default editor behaves. By disabling the mu-plugin, we can make sure that it's not the one that's causing a conflict, renaming the folder back to mu-plugins should activate the plugin back.

    Please check this link to know more about mu-plugins: https://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins

    But all my popup stuff vs general notes is missing.. So I guess I need to ferret away at this next step?

    I have made a bit more tweak to your shortcode in the appointments page, by adding description arguments to it:

    [app_services description="content"]
    [app_service_providers description="content"]

    Once you have assigned a description page under Appointments > Settings > Service, as shown in the screenshot of the previous reply. When you select a service, you'll get a description for the service according to the page set.

    You'll have to create a new page, since the current page assigned for Short Acupuncture service is more of an FAQ page.

    This would be the closest to which we could get, regarding showing a brief excerpt about your services, when we select. For any additional information you'll have to add that under your new /make-an-appointment page.

    Your old /make-an-appointment page was heavily customised, so If you are looking to get an exact layout, I'm afraid you'll have to consider that done custom developed.

    I hope this helps. Please let me know if I have missed out anything. Have a great weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Shelley Beer

    Nithin thanks you so much.. I was working 9 -5 toady ( Saturday) so did not get a chance to get back to this .. I cherish your detailed efforts and guidance .. I'll do the mu-pug in conflict test and your suggestion to provide a service page description for each service ss a good one- it may work around the developer of my heavily customised app being unavailable to assist me to restore my app
    I hope you have a good weekend too !

  • Shelley Beer

    Nithin- I read the link..thank you for this detail - it tells me how to activate the mu-plug-in, not how and why to rename it to test for conflict..

    Look how far I have got - I'm a bit nervous to change the name of the mu-plug in

    As it is called SYSTEM in wp-admin , if I rename it, I expect it to crash the site? If you suspect it is an issue, how do I replace it ?

    WHY am I trying to deactivate it?

  • Nithin

    Hi Shelley Beer,

    Hope you are doing good today. :slight_smile:

    Thanks for sharing the screenshot, I thought it must be custom plugin, but it seems like the mu-plugins in implemented by Godaddy, so I guess it should be fine. I was in favour of deactivating this, because when your page editor loads, you'll have to click the text editor mode, and then the visual editor mode in order to see the content, it could be some caching enabled by GoDaddy which is causing this, I'm not sure though.

    I just wanted to eliminate that issue, so that your system runs smoothly, since the plugin is from Godaddy, I'm not sure whether it would crash or not, unless I could read the code. But if you aren't comfortable in deactivating, it's fine for now, I made that suggestion thinking it was a custom plugin.

    Kind Regards,
    Nithin

  • Shelley Beer

    Nithin , It is not possible to determine this way . Despite having access to all the previous versions of the page, via "browse" action.. since the site was reconfigured via turning off all the plugins, testing then reactivating them , the old browsed versions no longer behave the same .. I don't think I can determine a date the page was correctly displaying visual without having to click on text tab first

  • Nithin

    Hi Shelley Beer,

    Even I did perform a plugin conflict test, to rule out any conflicts, but it didn't make any difference. It could either be a caching issue that's causing this effect, or maybe the mu-plugins is conflicting somewhere, because that's the only plugin which I didn't test.

    If you are still looking to troubleshoot this issue, you can send credentials by using our secure contact form: http://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic.

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Shelley Beer

    Nithin I am trying to progress the new page you asked me to start again..

    What do I need to do if the preview page gives this error ?

    Warning: array_filter() expects parameter 1 to be array, null given in /home/content/n3pnexwpnas02_data02/99/3493899/html/wp-content/themes/spalab/framework/theme_metaboxes/post_metabox.php on line 254

    Warning: array_unique() expects parameter 1 to be array, null given in /home/content/n3pnexwpnas02_data02/99/3493899/html/wp-content/themes/spalab/framework/theme_metaboxes/post_metabox.php on line 254

    Warning: array_filter() expects parameter 1 to be array, null given in /home/content/n3pnexwpnas02_data02/99/3493899/html/wp-content/themes/spalab/framework/theme_metaboxes/page_metabox.php on line 550

    Warning: array_unique() expects parameter 1 to be array, null given in /home/content/n3pnexwpnas02_data02/99/3493899/html/wp-content/themes/spalab/framework/theme_metaboxes/page_metabox.php on line 550

  • Nithin

    Hey Shelley Beer,

    I just tried to create a new page /test-page, but the preview works fine. I also tried to check the preview of existing pages, but I wasn't able to replicate this error in your website.

    Is it related to any specific page? Do you have Debug mode enabled? You can check that in your wp-config.php file, located in your root directory, and check whether you have defined:
    define('WP_DEBUG', true);

    If yes, change it to:
    define('WP_DEBUG', false);

    If debug mode was already disabled, this could be a conflict, did you recently edit your theme files? As it's caused by a filter returning invalid value, performing a plugin/theme conflict test should rule whether any plugin is causing this issue.

    Please let us know how that goes, so that we could help get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.