Remove Render Blocking Resources stays 0

I would like to ask what is achievable normally as % under REmove render blocking.
I think I did everything possible under improvements and still shows red ond 0
Also please check the score on mobile. We are using another software that our customer logs into to view reports. This render blocking issue is showing up on those reports as well and the customer is concerned. The main reason why we wanted to use your membership was to solve render blocking issues.

  • Adam Czajczyk

    Hello Linda

    I hope you're well today and thank you for your question!

    I have checked your site. The "desktop" score is actually impressive, it's very high. The "mobile" score is indeed lower and there's "render blocking resources" issue but it's worth to be aware of the fact that it's not always possible to sort that out without breaking the site. Sometimes (quite often actually) it's a "bargain" - either no blocking resources at all but the site not working as it should or the site working fine but some render blocking resources.

    It's worth giving a try, though. The particular js file (served from WPMU CDN) is in fact 'jquery-core.js" file. You're also using Divi theme. Therefore, please try following steps:

    1. Disable caching in Hummingbird
    2. Go to "Settings -> General" page and set Endurance Cache level to "0 No caching"
    3. Go to "Divi -> Theme Options -> General" and near the end of that settings page disable "Minify and Combine JavaScript Files" and "Minify and Combine CSS Files"
    4. Go back to "Asset Optimization" in Hummingbird and "re-check" files

    At this stage, you would need to experiment with Asset Optimization settings (in "Advanced" mode), tweaking them manually, to move as many of them to the footer and defer as many as possible without breaking the site.

    5. Once that's done give it a moment to re-build minification resources
    6. After that enable back Hummingbird caching (but not Endurance Cache as it will interfere)

    Then re-check the site. If that doesn't help, switch cache off again, go back to Asset Optimiztion and try to move "jquery-core.js" file to footer and/or set it to load after page load and see if that breaks the site. If it doesn't that should fix the problem, if it does, I'm afraid that's something that needs to be ignored. After that enable Hummingbird cache back and check scores.

    Kind regards,
    Adam