Removing /blog/ from permalinks settings

Hi all, I have tried to remove the /blog/ part of the permalinks setting but it refused to go away.

I am now using the Branding plugin which I have set to hide the permalinks menu from my client's menu but still want to set all my main top wordpress install to not have 'blog' automatically in every post and page URL, and additionally I want to avoid this for all my new sites using the multi site set up.

Can someone advise please?

Thanks
Guy

  • Vaughan
    • Support/SLS MockingJay

    Hi Guy,

    Hope you're well?

    This is created by wordpress as default when you create a multisite that uses subfolders instead of subdomains.

    It's to prevent subsites from potentially causing conflicts with posts/page permalinks of the same name.

    there's a few posts here which may help.

    https://wordpress.org/support/topic/best-way-to-remove-blog-slug-wordress-34-multisite

    http://wordpress.stackexchange.com/questions/107901/remove-the-blog-slug-from-wordpress-multisite-root-node

    This is one reason I prefer to use subdomains rather than subfolders for multisite.

    Hope this helps

  • Guy
    • The Incredible Code Injector

    Thanks Vaugn. I wanted to avoid subdomains so that all content and links grew the core domain rather than create multiple weaker subdomains.

    It's such a shame wordpress insists on adding the word 'blog'.

    I'll have to find a solution as I can't accept every site having /blog in its URL.

  • Guy
    • The Incredible Code Injector

    I've enabled per slinks again from being hidden so I can give it another try to change but I can't see where the permalinks settings are in multisite.

    Can you advise where I should find the settings now?
    Thanks

  • calvinrogercanas
    • New Recruit

    Hello @Guy

    Hope you're well today and thanks for your question!

    I hope you can follow my tutorial cause it may get a little messy in between. :slight_smile:

    Note:
    You must select the root site (so in my case it is the site named ' / ' ).
    After you click the 'Settings' tab you must scroll down to find the 'permalink structure' OR use your browser's find functionality. :slight_smile:
    Remove only the '/blog' (without quotation mark). You must start the permalink structure with forward slash = /

    And I hope this can solve your issue. :slight_smile:

    Thanks,
    Calvin

  • Guy
    • The Incredible Code Injector

    Hi Calvin, thank you for your time and effort on this. That works for me thanks but the only problem is a number of wpmu dev plugins are saying they need me to "enable pretty permalinks" for them to work. I assume pretty permalinks is the custom option in the permalinks setting winces I've done a search and found nothing called that.

    Once I've enabled that the '/blog' appears back in the URL string.

    Any suggestions?

  • Guy
    • The Incredible Code Injector

    I think I've got it sorted some how. There seems to be an order by which you have to do things inc going into the actual permalinks settings of your top site in addition to the settings you've kindly described Calvin.

    The plugins seem to be happy too.

    Fingers crossed it doesn't revert :slight_smile:

    Thanks for your support.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.