Rename domain in a multi-domain configuration

Hi,

We are building a multi-site AND multi-domain website.
We did install everything on a testing server with names like
site1.lan
site2.lan
site3.lan
subsite1.site1.lan
subsite2.site2.lan
and so on... everything was fine.

Then we moved everything on a production server and used a search and replace script to update the whole WordPress database with the new names
site1.lan -> protestant.wng.ch
site2.lan -> eerv.wng.ch
site3.lan -> epg.wng.ch
In the "Multi-Domain" settings page, the Wildcard availability displays "unavailable" for eerv and epg but is ok for protestant.

In our DNS server everything looks ok for all the domains as we have CNAMEs for *.

If we add a new domain there, the wildcard is ok right after the creation.
I tried to delete one entry and re-create it but it's still "unavailable"...

Do you have an idea of how we can rename correctly domains in those kind of installations ? And by the way correct our problem ?

Thanks !

  • Jack Kitterhing

    Hi there @Stephane,

    Hope you're well today and thanks for your question! :slight_smile:

    Just to clarify, when you done a find and replace on the sub site names, you assigned them a full domain?

    As Multi domains, allows you to create sub sites on those domains you added, such as sub.domain1.com sub.domain2.com etc, but it doesn't allow mapping of the domains, for that you need domain mapping https://premium.wpmudev.org/project/domain-mapping/ to map a sub.domain.com to a domain2.com.

    Please advise, I'm here to help. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • Stephane

    Hi Jack !

    Well, we are using also the domain-mapping extension.
    Just to clarify the process we did (my first mail was not that clear).

    The first setting we had was on our local server, with MULTI-DOMAINS and DOMAIN-MAPPING plugins installed
    Primary site : protestant.lan
    then we did add as multi-domains
    - epg.lan
    - eerv.lan
    using the plugins. The DNS was configured to work with wildcards.

    Then we moved everything on a production server.
    We launched the search and replace script to change
    - protestant.lan -> protestant.wng.ch
    - epg.lan -> epg.wng.ch
    - eerv.lan -> eerv.wng.ch

    This script browse all the database and do a kind of brutal replace.

    Now here is the situation in the admin : http://extranet.wng.ch/transfer/screenshot.png

    the "eglises.wng.ch" has been created after this process.
    I tried to delete the other and re-create them but it's still not accepting wildcards.

    Cheers.

  • Jack Kitterhing

    Hi there @Stephane,

    Hope you're well today, thank you for the additional information.

    I've tried to check the DNS records of the domains above, but I get a can't access nameserver error and I get a 401 auth error when trying to visit the domain, it's possible this is blocking multi-domains, could you remove all auth checks and see if it works then? :slight_smile:

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.