Request timeout on snapshot pro backup

I am having problems trying to run backups on quite a few of my sites. Every time I try to run a backup I get this following error.

Request Timeout
This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact the administrator of this web site to increase 'Connection Timeout'.

Please help!

  • Dimitris

    Hello there Roxy,

    hope you're doing good today! :slight_smile:

    I've just made some tests in your site, here's my results.
    Firstly, I went ahead and edited wp-config.php file and inserted the following lines:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);
    // Snapshot definitions
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');

    Secondly, I've noticed some large files and folder in the root folder of this installation, so I went in wp-admin area under Snapshot -> Settings -> Global File Exclusions and inserted them in there, so we are sure that these aren't getting included in the snapshot file.

    I then tried to run a new snapshot (called "Snapshot - WPMUDEV Test") and I noticed that when the backup procedure was fetching media files (meaning the /wp-content/uploads/ folder), then the I/O usage of server was hitting its limit.

    Having said that, there are the followings workarounds that you could follow:
    1. Upgrade your account or contact your host to see if the can raise the I/O usage without the need for an upgrade.
    2. Keep a snapshot with everything else apart from media files and backup /wp-content/uploads/ folder manually via FTP.
    3. Use Managed Backups instead from Snapshot plugin. This will store your backups in our own cloud service (these can't be sent to Dropbox or any other "destination"), but you can take advantage of some definitions made for Managed Backups only, that could surpass this limitation (that's not guaranteed, you can give this a try though), simply edit the wp-config.php file and insert the following line just above the /* That's all, stop editing! Happy blogging. */ comment:

    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //100MB

    then run a Managed Backup.
    4. Find another host. Make sure to check their I/O usage before you signup as most host don't include these in their package description (even if they say its unlimited hosting).

    Warm regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.