Request Timeout when creating a snapshot in Snapshot Pro

I've been trying to create a new snapshot in Snapshot Pro. I have tried creating the snapshot on the local server as well as Google Drive. It has successfully worked before as I had created a successful snapshot on 23rd June 2018 on the local server.

I thought perhaps I needed to increase the execution time in PHP which I did from 150 to 3000, however I'm still getting the same Request Timeout error at exactly 86% every time. It always happens when it gets to the Plugins.

I setup the debug file and have attached it to be reviewed.

Thank you in advance,

Darren Utteridge

  • Patrick Freitas
    • Staff

    Hi Darren

    Sorry to hear that you are having this problem.

    Have you installed any plugin just before this issue start? If so, please deactivate the plugin and try to run a new backup. If you had no enabled any plugin wouldn’t you mind please, access the WordPress root folder using a FTP or cPanel access. Look for wp-config.php.

    On the wp-config.php above /* That’s all, stop editing! Happy blogging. */

    paste the code:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //100MB
    define('SNAPSHOT_IGNORE_SYMLINKS',true);
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);

    Try to execute the SnapShot Pro and see if the issue is gone.

    Let me know the results,

    Best Regards.

    Patrick Freitas

  • Patrick Freitas
    • Staff

    Hi Darren Utteridge

    How are you today?

    Wouldn’t you mind please grant the support access and I can have a closer look also I will need the FTP credentials to run further test.

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question:

    Subject: “Attn: Patrick Freitas”

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    Let me know when you send the informations.

    Have a great day,

    Patrick Freitas

  • Darren Utteridge
    • Flash Drive

    Hi Patrick,

    On the 23rd June, I updated all the WPMU DEV Plugins on this website. Since then, I’ve updated the SiteOrigin Page Builder and Widgets Plugins and Gravity Forms. I haven’t actually added any new ones. The last plugin that was new was Snapshot Pro.

    Thanks,

    Darren Utteridge

  • Patrick Freitas
    • Staff

    Hi Darren Utteridge

    Thank you for the new information.

    It looks a plugin update conflicting the backup process.

    I made some new test and there are 3 workaround to avoid this.

    1- I can see that I/O Usage is really high when the backup is running, you can ask the hosting provider and check if this can be increased.

    Once you have many plugins increasing the I/O memory would allow the Snapshot Pro has more I/O resources to deal with plugins folder.


    2- You can avoid the plugin backup. On Snapshot > Settings > Exclude the Plugin folder, using

    wp-content/plugins


    3- Figure out the plugin – This is more like a hardworking.

    3.1 – First Create a Full backup on cPanel or move the site to a stating site.

    3.2 – Login on WordPress root folder go to wp-content/plugins, rename the plugins folder to plugins-temp, it will becomes wp-content/plugins-temp then create a new plugins folder and move the WPMUDEV dashboard and Snapshot Pro plugin from plugins-temp to plugins.

    3.3 – Use the plugins-temp as step 2. Snapshot Pro > Settings > Exclude folder > wp-content/plugins-temp

    3.4 – Go to Snapshot Pro > Snapshot and create a new backup.

    3.5 – If this get 100% remove it, back to the plugins-temp and move another plugin to plugins folder.

    3.6 – Repeat 3.4 and 3.5 until figure out the problematic plugin.

    Best Regards,

    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.