"Resize Original Image” setting isn't working on WP Smush Pro

Hi,

1) Smush Pro refuses to resize my images to 1800px which leaves me with 7000px and 9000px images. I’m not sure when this stopped working, but I know it WAS. I have waited for the smushing progress to update and then refresh and still, no changes – still left with huge images.

2) I see a new image size called medium_large now that’s able to be “smushed”. I didn’t add that, so I looked into it and found out that WP added it back in 4.4. So why is it showing now and why is it set to 0px by 0px?

3) 3 of my images refuse to “smush”. They originally smush and I get a success message and then when I refresh the page… boom back to “you have 3 images that need smushed”… How do I find out what images these are and why it’s doing this.

I’m up to date on all my plugins and am a paying user. The website I’m currently building is on a staging server (safetyindi.wpengine.com) and I’m building this out on my own custom theme.

Please get back with me and fix this. I can’t move forward with development until I can start uploading images properly. Images of the above scenarios are attached below.

Thanks,
Tad

  • Kasia Swiderska

    Hello Tad,

    Would you mind allowing support access so we can have a closer look at this?

    I'm testing now Smush on my WPEngine site and I'm not able to replicate any of those issues.
    Images are resized, medium_large shows correct dimensions and every image is smushed in bulk smush.

    Would it be possible for us to do a plugin conflict test on that site?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Tad,

    I'm testing now resizing orginal images on your site and that is working well. I uploaded image with dimensions 4600x3450 px and it was resized to 1800 x 1350 (you can check it in the media library P1000521.jpg). It was done on upload.

    How can I replicate this on you site?

    2) I see a new image size called medium_large now that’s able to be “smushed”. I didn’t add that, so I looked into it and found out that WP added it back in 4.4. So why is it showing now and why is it set to 0px by 0px?

    I run plugin conflict test, but that haven't change the size of that image - so last thing would be to check if theme that is used on the site is not changing anything (switch to default WordPress theme like twenty seventeen). I also saw some must-use plugins - I could not deactivate those from wp-admin, so you would need to do that manually (using FTP account and renaming the mu-plugins folder in wp-content).

    3) 3 of my images refuse to “smush”. They originally smush and I get a success message and then when I refresh the page… boom back to “you have 3 images that need smushed”… How do I find out what images these are and why it’s doing this.

    Do I need to wait longer time to see that issue? There were 3 images, I bulk smushed them, refreshed page three times, logout and login and bulk smush shows me that everything is smushed.

    kind regards,
    Kasia

  • Tad

    1) I've retested this and resizing is only working when uploaded in list view mode, not grid view. You can take an image, upload it when viewing media via list view and it resizes perfectly - BUT if you switch the view to grid view (which is what I use by default), then the same image will NOT resize.

    2) Problem still persists

    3) All 3 images come back when you click "re-check images" in the upper right hand corner.

  • Kasia Swiderska

    Hello Tad,

    1) I've retested this and resizing is only working when uploaded in list view mode, not grid view.

    Could you please add the following definition in your wp-config.php file, and then see whether it works fine:

    define('WP_SMUSH_ASYNC', false');

    Please make sure to place the above code, just before the line /* That's all, stop editing! Happy blogging. */

    2) Problem still persists

    3) All 3 images come back when you click "re-check images" in the upper right hand corner.

    I checked your media library and every image is smushed there, so it looks like problem with stats of the Smushed images. Do you have ability to clear cache for your site?

    As for the image size I will ask developer why Smush is showing it this way and let you know what he said.

    kind regards,
    Kasia

  • Tad

    1) The snippet you sent me worked, but I needed to remove that odd apostrophe at the end of the last argument. What is that snippet doing and why is it necessary to use?
    2) What is the update on this?
    3) You obviously did NOT click "re-check" images in the upper right hand corner. Again, all images say "compressed" until you click recheck and then boom - three images come back as un-compressed. So the questions remains... why won't WP SMUSH PRO compress these three images and what 3 images are these? How do I know which images they are?

  • Nithin

    Hi Tad,

    Hope you are doing good today. :slight_smile:

    1) The snippet you sent me worked, but I needed to remove that odd apostrophe at the end of the last argument. What is that snippet doing and why is it necessary to use?

    What that snippet does is disable Asynchronous optimization. You are right with that apostrophe, it code should be:
    define('WP_SMUSH_ASYNC', false);

    Regarding 2nd, and 3rd issue I would like to check your website to have a better idea. At the moment, the support access isn't enabled. Could you please enable support access, so that we could give a closer look at this?

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Tad,

    I could see the issue that was raised in 2nd, and 3rd points, and it's really odd. To have a better idea regarding this, could you please send us your credentials so that we could give a closer look, and also check with the developer regarding what could have gone wrong here.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.