Restored snapshot to new server, kicks me back to wordpress installer script

Read the post here:
https://premium.wpmudev.org/blog/easy-migration-snapshot/

and decided to try it since I was in the process of migrating a site out of a multisite onto a single site new installation on a different server. This sounded perfect! Followed the instructions, but after restoring the backup onto the new server, as soon as I leave the restore page for any other page in the admin panel or the site itself, I am redirected back to the wordpress installer that comes up when you first install wordpress.

Any ideas?

  • Chris
    • The Incredible Code Injector

    Hello Ashok.

    I am and thanks for asking, I hope you are well, as well!

    So I have granted access to the new single site, the snapshot I took from the multisite, is in the default uploads folder on the single site. I have imported it for you. I have reinstalled a fresh wordpress for you and added the custom theme and the snapshot plugin for you. Have at er! :wink:

    Best of luck, let me know what you find!

    If you need access to the multisite to try and take another snapshot, let me know and I will grant access there for you as well.

  • Chris
    • The Incredible Code Injector

    Hey @Ashok - yes, see my post above from Wednesday. I created a fresh single site install of wordpress for you and installed the custom theme that I am using, I installed the support access plugin and snapshot plugin, I installed the site related plugins, I even uploaded the snapshot (taken from the original subsite - that was failing and lead to the support request) to the standard default snapshot location on the new server. I have granted access to both servers. My records indicate that you have accessed the server with the multisite, but not the server with the single site.

    Cheers!
    Chris

  • Ash
    • WordPress Hacker

    Hello @Chris

    I hope you are well today.

    I, with one of my colleague can confirm that there are some issue on restoring a subsite into a single site. So, I am marking this as a bug and reporting to the developer.

    We appreciate your patience on this.

    Cheers
    Ash

  • Chris
    • The Incredible Code Injector

    Hi @Ashok - thanks for letting me know.

    Now I have another problem though...

    I decided to go ahead (since my move out date is rapidly approaching) and move the multisite and the subsites over from my old server to my new server. My thoughts were that I could move that blog we were attempting to move - out of the multisite to a single site later, when the bugs are fixed.

    So, I created a new from scratch multisite, instead of migrating the main site I just set it up manual since I am not currently using it anyway and there isn't anything really on it except a coming soon page... I installed all of the plugins and themes that I currently use and then created the subsite, the users, and activated the theme and plugins for it. Then I went to the old server and made a snapshot of that subsite. I imported this into the new multisite. I received a message that my database needed repair and to copy a define function into my wp-config.php file, which I did, reload the page and error cannot connect to my database. I left it like this.

    Any ideas? did I find another bug?

    I have granted access to both servers.

    Cheers and thanks in advance!
    Chris

  • Chris
    • The Incredible Code Injector

    This is the list of tables that could not be repaired...
    rxAjhNcDWw_2_posts: Table 'horsesoc_wordpress.rxAjhNcDWw_2_posts' doesn't exist
    rxAjhNcDWw_2_comments: Table 'horsesoc_wordpress.rxAjhNcDWw_2_comments' doesn't exist
    rxAjhNcDWw_2_links: Table 'horsesoc_wordpress.rxAjhNcDWw_2_links' doesn't exist
    rxAjhNcDWw_2_options: Table 'horsesoc_wordpress.rxAjhNcDWw_2_options' doesn't exist
    rxAjhNcDWw_2_postmeta: Table 'horsesoc_wordpress.rxAjhNcDWw_2_postmeta' doesn't exist
    rxAjhNcDWw_2_terms: Table 'horsesoc_wordpress.rxAjhNcDWw_2_terms' doesn't exist
    rxAjhNcDWw_2_term_taxonomy: Table 'horsesoc_wordpress.rxAjhNcDWw_2_term_taxonomy' doesn't exist
    rxAjhNcDWw_2_term_relationships: Table 'horsesoc_wordpress.rxAjhNcDWw_2_term_relationships' doesn't exist
    rxAjhNcDWw_2_commentmeta: Table 'horsesoc_wordpress.rxAjhNcDWw_2_commentmeta' doesn't exist

  • Chris
    • The Incredible Code Injector

    Hi @Ashok - I'm sorry, I'm not sure I understand what you are asking me to do. You would like me to create a new multisite and try again? What do you mean by "try in two multisite"?

    I wondered if it is a bug in my old multisite or database since this migration site failed in multisite to single site and now multisite to multisite. As added information, that old server had a partitioned database using the WPMUDEV tool that is now decommissioned. I wonder if the snapshot is including all of the tables? I'm sorry, I am not very knowledgable on databases.

    Cheers!
    Chris

  • Ash
    • WordPress Hacker

    Hello @Chris

    How old your multisite is?

    that old server had a partitioned database

    Would you please tell me more about this? :slight_smile:

    And yes, snapshot includes all of the tables. You can choose table names though when you create snapshot. So, if you want to choose, you can select from there.

    I'm sorry, I'm not sure I understand what you are asking me to do. You would like me to create a new multisite and try again? What do you mean by "try in two multisite"?

    Well, I meant to create two fresh test multisite and take backup from one and restore in another, in the same server.

    But before, that please let me know about your database.

    Cheers
    Ash

  • Chris
    • The Incredible Code Injector

    Hey @Ashok - It was originally setup for me by the hosting provider using WPMUDEV plugin Multi-DB back in 2013 (thereabouts, I think) when I moved to that VPS from a shared hosting account. It is currently at v3.2.5.

    Cheers!
    Chris

  • Chris
    • The Incredible Code Injector

    Hi @Ashok. Yes - I am trying to migrate my multi site and the final two sub sites that remain in it. This has a multi db database. My new server I don't think i need multi db and since multi db is decommissioned my plan was simply to not use it moving forward. My long term goal is to move the krowchukdressage site to its own cPanel account on my own server, but for short term it can stay in the multi site since you mentioned above that moving it to a single site was running into a bug that you are working on.

    I just need to get these final sites migrated this week before my service ends on the old server.

    Suggestions?

    Cheers!
    Chris

  • Chris
    • The Incredible Code Injector

    Hey @Ashok - thanks for the info. Rats, unless the developer thinks he can get this to work in the next few days.... I think I will just have to bite the bullet on this one and attempt to manually do the migration using Wordpress built in export and import xml function. Not all of my media came across that way either... and I will just have to do a lot of editing.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.