Restoring subsite to single site installation with Snapshot is not restoring everything.

I was trying -using Snapshot- to migrate a subsite (from multisite installation) to single site installation hosted on WPMUDEV server.
The restoration process was done with no errors. However, plugins and media files weren't restored.
Although, I can see that plugins and media files are included in the Snapshot compressed file.

  • Nithin
    • Support Wizard

    Hi David,

    Please do note that Snapshot Pros primary purpose is for backup, and to restore in the same subsite or network. The plugin isn't meant for migration purposes, and migrations aren't Snapshots strong aspect. You could still perform migrations via Snapshot, but I'm afraid, there are chances you'll see anomalies as noticed, and it'll require manual changes to fix any differences noticed.

    You'll have to either create a new snapshot backup and re-try a new restore again to see whether it's an issue specific to the zip archives.

    Since only the plugins, and media files are missing and since the Database seems intact after restore, easiest would be to manually upload those folders into the destination website, and it should work out of the box.

    If you want we could manually upload the missing plugins, and media files if needed to the destination. Please do let us know so that we don't make any unwanted changes without your confirmation. Have a nice day ahead.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi David,

    I have moved the plugins into the website, before making sure to move the uploads files, would like to confirm whether the site you migrated into the wpmudev.host is the main site, right?

    So, the uploads folders would be the ones dated from 2012 to 2019 inside:
    /public_html/wp-content/uploads

    And the folder one, under:
    public_html/wp-content/uploads/sites/1/

    Right?

    Just making sure before making any unwanted changes. Please do confirm, so that we could help get the media files uploaded asap.

    Kind Regards,
    Nithin

  • David
    • The Incredible Code Injector

    No. This is a different site. This site is mainstaycleaning.com. It is going to mainstaycleaning.wpmudev.host. The restore from full backup is to get a deleted site (expediteyourbusiness.com) recovered and moved to a single site hosting account. The problem with Mainstay cleaning is that when snapshot restored, it did not restore the images from the original snapshot. I need the images moved.

  • Nithin
    • Support Wizard

    Hi David,

    I gave a closer look, but it seems like the images are missing especially for the 2017 directory in the source website, ie under:
    public_html/wp-content/uploads/sites/15/2017/

    All the folders inside 2017 are empty directories. Am I checking the correct path? There are only 2 images present inside the following folder:
    /wp-content/uploads/sites/15/2017/09/

    Rest of the directories are empty for 2017, and most of the images in the destination website are loaded from the 2017 folder.

    I checked the Snapshot "Mainstay Snapshot", and downloaded to check whether it has any images, but it only has images from /2017/09 folder, which should be correct as the source only has images on these folders, under wp-content/uploads/sites/15/2017 path.

    However, when I checked the dashboard of the source website, it seems to be loading these missing images but from a different source. Could you please check, and point out the correct path for those images in the server side? Not able to find those images when checked via cPanel.

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.