Restrict Plugins That Can Be Used by WPMU Bloggers

I would like to control what plugins my WPMU bloggers can use. Is there anyway to restrict on a per blog basis, just like can be done with themes? All ideas are welcome.

Thanks,
David