Revolution slider doesn't work when Hummingbird CDN is enabled

Revolution slider stopped working after I enable Hummingbird CDN.

  • Nithin
    • Support Wizard

    Hi Frank Lindner,

    Such issues occur when the related files in the Slider Revolution are loading before the jQuery files when Asset Optimization is enabled.

    I tried to move a couple of files via Asset Optimization in Hummingbird and tried to further tweak it, but I'm afraid it doesn't seem to help much.

    I'm checking with the developer to see whether there are any further improvements that could be done in the Asset Optimization side to make this work, or not.

    Will keep you posted once I get further feedback asap. Have a nice day ahead.

    Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Frank Lindner,

    I got an update from the developer, and we would like to further tweak the Asset Optimization regarding the Revolution Slider settings enabled in Global Settings in the plugin side, and see how it goes by further tweaking the Asset Optimization.

    Such issues noticed are common due to conflicts, and it would be better to further test in the staging website shared.

    Seems like, on testing in Staging website, the Hummingbird CDN isn't loading nor working due to the staging website being protected behind a login screen.

    Is it okay, if I temporarily disable the login screen in the staging so this could be further tested? We don't want to make any unwanted changes without confirming with you. Please do let us know.

    I have discovered another error. WP Bakery page builder will not open to edit a page; it just hangs with a white mask over the page. This is with cdn disabled.

    I could notice Hummingbird was disabled on your live website. I just quickly enabled the plugin and gave a quick test, and the WP Bakery builder seems to load fine in the backend.

    I then further tested by clicking the "Edit with WPBakery Page Builder" button in the frontend and could notice what you meant. This is due to minification done by the Asset Optimization causing to hang.

    The purpose of Asset optimization is to minify and combine the assets loaded in the website and such steps are something which should be performed once all the changes, and tweaks are finished in the website side via the Builder. Since the homepage already had asset optimization enabled, and when trying to edit the homepage the WP Bakery was trying to load assets specifically in the admin side causing this conflict.

    I'll make sure to bring this into our developer's attention so that we could see any further improvements could be done regarding this. However, you could still load the WP Bakery builder via the backend, and edit without any issue.

    Please do let us know whether you are comfortable with us further testing the issues with Slider plugin in the staging website by disabling the Login screen in staging so that we could help get this sorted asap.

    Kind Regards,
    Nithin

  • Frank Lindner
    • Flash Drive

    Hi Nithin,
    Yes I disabled Hummingbird to make some edits on live site. I will check out the backend as you suggest, as a temporary measure, until you get things sorted.
    If you need to disable the login on the staging site then I don’t have any objection to that, however you wouldn’t leave it without login security would you?
    Regards,
    Frank Lindner

  • Nithin
    • Support Wizard

    Hi Frank Lindner,

    Sorry for the delay in getting back to you. Yes, I have tested further in staging, and have enabled the login screen back once done.

    I'm afraid, I tried further tweaking the settings but still, the issue occurs with WPMU DEV CDN. This could be more related to a conflict that could arise if there are new features in the plugin side. Tried tweaking the settings in Slider Revolution > Global Settings, and also tried moving the related Slider plugin files, under Hummingbird Pro > Asset Optimization.

    I'm bringing this again with our developer to see what could be done in such context, will keep you posted shortly once this is troubleshooting further.

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi Frank Lindner,

    On giving a closer look, our developer was able to notice where the anomalies were caused. The Theme already had an option to move the jQuery scripts, which was causing the issue.

    We have disabled the Move jQuery scripts to the footer option in the theme side, under Impreza > Theme Options > Advanced, and further tweaked the Asset Optimization under Hummingbird Pro > Asset Optimization page except for the jquery.js file, and now the website is loading fine with Hummingbird CDN enabled in your staging website.

    I have made the relevant changes in your Live website too, and the pages are loading fine with WPMU DEV CDN enabled. However, since it's a live site, I have temporarily disabled the CDN.

    Please do activate the Hummingbird CDN in Asset Optimization, and let us know if you notice any further anomalies regarding this on the live website. It should be working fine now.

    Have a nice day ahead. :slight_smile:

    Best Regards,
    Nithin

  • Frank Lindner
    • Flash Drive

    Nithin,

    I have enabled CDN in Hummingbird/AssetOptimisation but unfortunately I still see the same error (Rev Slider is not working and same JS message appears. Also I am unable to load contact form in 'Contacts' page and some similar forms will not load either (Super Forms Plugin).

    Regards,
    Frank

  • Nithin
    • Support Wizard

    Hi Frank Lindner,

    Sorry to hear the issue occurred again. Seems like it occurred after a while, I did browse a couple of pages where it had the sliders but wasn't able to notice the issue last time.

    Could notice the issue once I activated it again in the Live website, but it seems to work fine in the staging website.

    Seems like the following plugin "Ultimate Addons for Gutenberg" is causing conflicts, I have further tweaked the files related to the mentioned plugin in the Live website. And the contact us, homepage, banquet pages seems to load fine.

    I have disabled the CDN. Could you please check, and see whether you are able to replicate the issue again in the Live site once Hummingbird CDN is enabled?

    Kind Regards,
    Nithin

  • Frank Lindner
    • Flash Drive

    Nithin,

    I have enabled the CDN and everything seems to be working at this point of time.
    I really hope it continues to work. I have come back to WPMUDev and encountered a lot of issues but I hope, if we can get them resolved, to migrate the site to MPWUDev hosting.
    I really appreciate the effort WPMUDev has put into assisting me get these issues resolved.

    Assuming this CDN problem is behind us now; the big issue remains the backup (another ticket). Although my current Host providers were able to complete a backup (shown in Dashboard) I have not been able to replicate that and continue to get 504 error.

    I believe we are slowly getting things resolved and hope I continue to receive the same excellent service from WPMUDev, and look forward to a long mutual relationship.

    Regards,
    Frank

  • Nithin
    • Support Wizard

    Hi Frank Lindner,

    Glad to hear the CDN is working fine at the moment in your side too, please do let us know if you have any further query related to this.

    Assuming this CDN problem is behind us now; the big issue remains the backup (another ticket). Although my current Host providers were able to complete a backup (shown in Dashboard) I have not been able to replicate that and continue to get 504 error.

    Regarding the above query it seems like my IP got blocked by Defender, and was no longer able to access the dashboard via support access, so wasn't fully sure where exactly you are getting the 504 error.

    If it's a query related to Snapshot Managed Backups please do feel free to open a new chat or ticket, and we'll make sure to give a closer look.

    Also, our team can also help with manual migrations to your site hosted in WPMU DEV, so please do raise the query in a chat, and our support agent will guide you further regarding this.

    Link to open chat:
    https://premium.wpmudev.org/hub/support/#wpmud-chat-pre-survey-modal

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.