Running snapshot ending in internal server error

Hi there,
as the subject statet already, wanted to do s snapshot of one of the sites,.... All tables had been processed, but when it comes to the files, I receied the following error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, service@webmailer.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Any idea?

  • boris_carl_max_uhlig

    Hey Patrick ...

    thanks for the feedback!

    1. The error log doen't give any specific error which would assist in tracing the problem.
    2, The uploads folder is writeable ...
    3. Scheduled and recurring Snapshots for DB only are running smooth and perfect
    4. The problems occurs only, when I want to "snapshot" the individual site INCLUDING files (themes, media, plugins) within my Multi-Site Environment

  • Ash

    Hello @boris_carl_max_uhlig

    I hope you are well today.

    This is mostly a host related issue. Who is your host? Would you please ask your host if they have any restriction to access those folders?

    But before that, I will suggest to run a plugin conflict test to check if any plugin is setting any restriction. So, would you please run a plugin conflict test? Please deactivate all plugins except this one and check if you still face the problem. If not, then enable one by one and check which one is causing the problem. You can see the flowchart here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let me know what you get.

    Cheers
    Ash

  • boris_carl_max_uhlig

    Hi Ash,

    with all respect, I've tested snapshot before and in exactly that fashion ...

    I've disabled all plugins, except your Multi-site plugin and Snapshot ... Always to no avail ...

    To make sure, there is nothing wrong with Wordpress itself, I've invested almost 26h since yesterday to

    1. install a fresh WP 4.1 Multi-site

    2. installed and activated all relevant plugins (see attachment)

    3. created all post/pages etc. manually

    then

    4. Have been able to perform a successful snapshot !!!

    then

    5. upload and assigned all remainng media files post by post, page by page (what took ages due to my very low bandwidth)

    and after my site was back

    6. I've tried to perform another snapshot, unfortunatelly with the same error as before when it comes to media files,but snapshotting only the DB works always fine!

    The site contains about 138MB of Mediafiles (1645 files) only!

    And of course I've asked my ISP about any restrictions etc. but there are none ...

    And again, I need to mention, that snapshot works fine on the same server, ISP etc. until January 11th, 2015 ...

    Really expecting some extensive research on what is causing this issue.

    Cheers, Boris

  • Michael Bissett

    Hey @boris_carl_max_uhlig,

    Wow, you've definitely put a lot of time into this, thanks for providing that additional information here! :slight_smile:

    I didn't see an attachment posted here, but I am curious about this:

    And again, I need to mention, that snapshot works fine on the same server, ISP etc. until January 11th, 2015 ...

    I'm curious as to what changed around that time, did you happen to update any plugins (like Snapshot) around that time?

    Oh, and by ISP, I take it you're referring to your hosting provider, correct? Would you mind mentioning who that would be? :slight_smile:

    I'd like to have a deeper look at your site here, could you please send in the following:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks a bunch! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @boris_carl_max_uhlig, thanks a bunch for your patience here!

    I've been digging into this for you, but even after doing the following:

    - Increasing max_execution_time to 300
    - Increasing the memory inside of Snapshot (as well as WP_MEMORY_LIMIT & WP_MAX_MEMORY_LIMIT)
    - Temporarily disabling the /updraftplus/ plugin (saw it come up in the log)
    - Switching the compression option to "PclZip"
    - Running the snapshot without being in "Live" mode (meaning, I'm not watching the process in real time, I just clicked on the "Run Now" button)

    I'm still finding that it keeps stopping at the 34%. :disappointed:

    I've done some digging around, and it seems like the media files are being processed (as noted in uploads/snapshots/_logs/_sessions/1422377664_session.php), but at this point, it seems like we'll need to check out the server error log to see as to why Snapshot's having a hiccup here.

    Could you send in a copy of that please via email, so that we can look over?

    Please advise,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.