Save settings button is missing at the bottom of the appointments plus general settings page.

Hi, I cannot save settings under appointments plus/settings/general as the save button has disappeared from the bottom of the page .

This is a clean build of WP 4.2.2 and empty DB, no restore, and only your 1.4.8 Appointment plus plugin and dashboard installed.

I've attached a screenshot showing this problem with the button missing at the bottom of the page.

Any help would be extremely appreciated as frustration is getting the better of me as I've been trying for fix this for almost a month now.

Thank you

  • Nathan

    Hello Jude,

    Finally worked out what's causing the problem. It seems since the the last few updates of appointment +, the Additional fields add-on within appointment + now breaks the plugin so the save button disappears. Disabling the Additional fields add-on in AP+ brings the save button back.

    This can be easily replicated.

    If this could be escalated to the developer to fix, it would be great as to be brutally honest, to have an appointment plugin that doesn't have a zip/postcode required or optional field by default on a customer appointment address form is shockingly ridiculous, especially in an example where you're taking mobile appointment bookings from customers and use the zip/postcode for additional location search for use with a GPS system such as google maps/tomtom/copilot/garmin/in-car/ etc, also in the event customers have imputed part of their address incorrectly, zip/postcode is extremely useful.

    I know obviously in the states your zip codes aren't as efficient in identifying a location closely as how the postcode location works in the UK but I assume you don't just market the AP+ plugin for use in the US only, that said, being honest, I don't think I've ever seen a appointment contact address form without a zip or postcode field.

    This is purely why I had to use the additional fields addon to create the zip/postcode field in the first place and make it a required field.

    Anyway, after a extremely long headache, I finally have an answer. Hopefully you guys can get this fixed or do away with the additional fields addon altogether and integrated the feature into AP+ by default.

    If in the meantime anyone knows a quick fix to add zip/postcode back, I would be extremely grateful.

    Thanks for time and help Jude.

    Nathan

  • Michelle Shull

    Hey Nathan!

    I actually think something else may be going on here. I've got the Additional Fields add on active, and I can still see the whole Appointments settings page including the save button. You're also missing Advanced Settings, Notification settings, and Payment settings.

    Can you try turning the additional fields add on back on, if it's off, then do a plugin conflict test? We've got a guide here for that: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/ If you're using any caching plugins, try flushing your cache and temporarily disabling the plugin while you're checking on Appiontments +.

    Thanks!

  • Nathan

    I can see the settings page, I just cant save any settings. I've done the conflict tests already including checking memory etc, this has been going on over a month now.

    As already mentioned earlier, I completely rebuilt WP4.2.2 from fresh with ONLY your AP 1.48 plugin installed so there's NO plugin conflict as nothing else is installed, still doesn't work. As soon as I enable additional fields addon, the save settings button at bottom of the page disappears from AP+ settings/general tab.

    Switch off additional fields addon and its back.

    I was told the dev of the plugin would be flagged to respond to this thread. Many days later still nothing.

    I have offered remote access to look and see for yourself, still nothing.

    Extremely disappointing paying a years subscription for support and this specific issue with AP+ keeps getting overlooked.

    I have remote access open again now if someone cares to look at the issue and see for themselves.

    Thanks

  • Jude

    Howdy Nathan

    Can you please send in

    Subject: "Attn: Jude Rosario"
    - WordPress super admin/ admin username + password
    - FTP credentials (host/username/password)
    - cPanel details
    - phpMyAdmin details ( To check database )
    - MySQL details ( IF you dont have phpmyadmin)

    -link back to this thread for reference

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Jude

  • Nathan

    Hello Jude, any fix for this yet as this has been going on for months now?

    As I noticed recently I'm not the only person who has this exact problem just extremely annoyed I had to go through tons of effort and wasted time and completely rebuild my site from scratch only to conclude its obviously a bug with the latest version of AP+.

    You said to me a month ago the developer would look into this, still nothing?

    regards

    Nathan

    https://premium.wpmudev.org/forums/topic/additional-fields-not-working-in-appointments#post-920833

  • pxwm

    Hi @Michelle Shull and @Jude - I hope you don't mind me chiming in

    Hi @Nathan

    I have a fairly clean A+ demo site with the additional fields add-on set and thought I would upgrade to A+ v1.4.8 and also upgrade to latest wordpress 4.2.3 to try and help out.

    I can confirm on upgrading the 'save settings' button at the bottom of the A+ settings 'General' tab was still visible.

    I then decided to:-

    Remove all the additional fields and saved
    Deactivate the additional fields add-on
    Activate the additional fields add-on
    Add a couple of new additional fields and saved
    Upgraded the twentytwelve theme to v1.7 and still okay

    To confirm completing all of the above I can confirm that the Save button at the bottom of the A+ settings 'General' tab was still visible.

    You mention your site is a clean version and no plugins and just wanted to check if you are using a default theme?

    If not you may wish to try reverting back to the twentytwelve theme and check

    I hope this helps
    Regards
    SteveB

  • Michelle Shull

    Hi, Nathan!

    I took another look. The issue is a 404 error from one of the scripts from your theme. I did not switch to a default theme, but as Steve suggests, if you quickly do a theme switch, I think you'll see that the issue is with your theme. You can also do a quicker check, if you have a developer browser extension that lets you disable javascript on a page. If you disable js, the fields pop right back up again after a refresh. (to apply disabling js.)

    This is the exact file: /wp-content/themes/Rejuvenate/js/_admin-install.js

    To attempt to fix this, try uploading a freshly-downloaded copy of the latest version of Rejuvenate. There's a chance that file became corrupted, which means overwriting it with a fresh one should fix it.

    There's also a chance that file has been removed/replaced in a recent update to the theme, but is still referenced in another file. This may not have become apparent until the latest version of Appointments+. If this is the case, letting the theme developer know the issue you're having (The 404 error on the above file) they may have a quick fix or solution. I checked in our email system to see if I could find your login details so I could check on the file myself, but I didn't see them in Jude's inbox or closed mails.

    I installed twenty fifteen, but it's not been activated. If you don't want to test that way, you can simply delete it.

    Thanks for your patience here, but this issue isn't a part of Appointments+. There's a missing/corrupt script in your theme.

    Hope you're looking forward to a nice weekend.

  • Nathan

    Unfortunately your theory is a little flawed, I've had the same template from scratch for over a year at around the same time I purchased your AP+ plugin which I have been using on the same site and template with additional fields addon enabled so that I can add a zip/postcode field to an address form. Crazy it's not there by default and requires an addon just for that but I guess thats someone else's logic.

    This has been working fine in all that time, all that has changed my end is upgrading your AP+ plugin a month or so ago to v1.4.8.

    I have taken your advice anyway and switched to standard default WP 2015 theme and it still doesnt work. The save button is missing still with additional fields addon enabled. I have cleanly reinstalled templates twice.
    I have left it in this state so you can look for yourself with the WP 2015 theme enabled.

    I have been troubleshooting your plugin for almost 6 weeks now and havent got anywhere further. I have paid for support for a year and have been told the actual developer would provide input in this thread, 4 requests later, still nothing.

    If you have read through this long thread, I recently COMPLETELY rebuilt the WHOLE site from scratch, so clean 4.2.2 WP and your plugin only, no themes, No DB restores, no additional plugins for conflict elimination, still doesnt work. Changed memory settings, enabled debugging, clean DB, error checked DB etc etc.

    The fact you have another customer now reporting the exact same issue in another thread is obviously leading to general issue with the plugin with additional fields addon enabled. The plugin works fine without Additional fields, but how many people are using the ADD fields addon is probably very limited to even notice the bug in the first place.

    I have spent way too much time debugging your product with loads of ideas/guess work from your support staff to try this and that. I dont mind doing this but its becoming beyond a joke now.
    I have paid for support of the product which appears at this point to be a complete waste of money as it takes ages to even get a response in the first place which completely contradicts your advertising stance of support.
    Why hasnt this been escalated to the actual developer as requested and even recommended by your own staff?
    If you cannot provide a resolution or dev direct support, please can I request a refund so I can purchase an appointment plugin that does work without any issue such as bookly responsive AP booking plugin?

    Idealy I would like to stay using your plugin as for this minor issue it works extremely well, hopefully we can get this finally resolved.

    Here's the link to the other customer's thread with the same issue opened very recently. Would be a very strange coincidence if we're both using the same template that you say has broken AP+ additional fields addon.
    https://premium.wpmudev.org/forums/topic/additional-fields-not-working-in-appointments#post-920833

    Many thanks

    Nathan

  • Jude

    Hey Nathan

    After super a thorough investigation and trying to reproduce this in every possible way including trying all versions of PHP starting 5.2 I can say that this is something specific to your install ( possibly the other member's ticket you linked to, she is yet to respond ).

    After trying a few tests on your site I can see a 500 ISE on the console, which means your server is not sending out the full page, can you please get me the EXACT error message ( Check PHP/Apache logs not WP) and I'll pass that on to the developer and make sure you get a satisfactory response and closure (solution) to this issue.

    This is definitely not usual behaviour here, we usually provide exceptional support.

    Cheers
    Jude

  • Ash

    Hello @Nathan

    Glad to know it's fixed now :slight_smile:

    Underscore templating is used in A+. It looks like:

    <input type="hidden" name="app-additional_fields[]" value="<%= encodeURIComponent(_value) %>" />

    <% is an underscore tag, and it is an asp tag too. So when asp tags is on in php.ini. it assumes encodeURIComponent is php function and causes a fatal error.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.