Scheduled backup didn't run

I set up scheduled backups last week, but it doesn't look like any backups have been made.
Special login details in chat.

    Mahlamusa

    Hello OWM admin

    I hope you are doing great today and thank you for contacting us. I am sorry that Snapshot Scheduled backups are not working well for you. I have seen the conversation you had with my colleagues via Live Chat Support and I am here to help you.

    Unfortunately, this is a complex issue and we have dealt with similar issues before and I am sure it won't be easier to solve without FTP access. I do understand your concerns but we need some kind of access to your files in order to pin point the cause for this issue. I have noticed that my colleague Rupok has given you some code to add to your 'wp-config.php' file to enable debug logging, if you have done that already then please share with us the fil '/wp-content/debug.log' so we can see if there are any debug warnings related to Snapshot, this will help us better understand your website's environment. You can share the file here by first renaming the file to 'debug.txt' then upload it to a file sharing platform like Dropbox or Google Drive, then share the link with us.

    To make things easier for you and our team, instead of sharing your FTP credentials, you can share your cPanel credentials witch will allow us to access your website's files and also some other cPanel settings. Again, this would be much more useful than FTP. You can create a temporal account that we can use temporarily, once the issue is resolved you can remove that account.

    For the time being, please do the following for me which is a major step towards resolving the issue:

    1. Enable debug logging as my colleague, Rupok suggested. You can do this by adding the following lines to your 'wp-config.php' file:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    2. Increase WordPress memory limit:

    define( 'WP_MEMORY_LIMIT', '256M' );

    3. dd the following lines which are specific to Snapshot settings:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);

    4. Increase max execution time to 300 or more by trying the following methods.
    a. Create or edit php.ini in your website's root and add the following line:
    max_execution_time 300

    b. In .htaccess add the following line:
    php_value max_execution_time 300

    c. in cPanel you can go to "Software > MultiPHP INI Editor", choose your domain and PHP version and change the value for max_execution_time to 300 or more

    After that you can try Snapshot again, please tryto set it to Daily so that we can have results soon for the Scheduled Backups, you can change later.

    If you want to share your cPanel / Hosting Control login credentials, then you should do so via our secure contact form, on the contact form, choose "I have a different question", then in the "Subject" line write: "Attn: Lindeni Mahlalela", then in the "Message" box add the following:
    - cPanel / Hosting Control Panel login details: login url, username and password
    - Link back to this thread for reference.

    Try the suggestions above, if none of them works then send the login details and we will do it for you. I hope all this helps.

    Please enjoy the rest of your day.

    Cheers,
    Mahlamusa

    OWM admin

    Thanks for the response.

    I have enabled debugging and backup is scheduled daily.
    I've been checking for a few days, but have not seen any errors related to Snapshot.
    The dubug file is massive, because another plugin is adding several lines every minute. I'm working on resolving that before I pass along one of the debug files.

    I will update this ticket once I've posted a debug file. Thanks.

    OWM admin

    A (anonymized) debug.log file has been uploaded here: https://drive.google.com/open?id=0B06qcNRJoFaxMzFxMmY0cjNWNVU

    I don't see anything related to backups.

    I did notice:
    - /wp-admin/admin.php?page=snapshots_full_backup_panel shows "Automatic backup currently running". I don't know if that suggest that a backup is running (but not completing)
    - In Cpanel (/frontend/paper_lantern/stats/errlog.html), I see entries like this in the error log:
    [Thu Jun 08 08:38:29.131106 2017] [access_compat:error] [pid 22208] [client xxx.xxx.xxx.xxx:45762] AH01797: client denied by server configuration: /[ROOT]/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://www.DOMAIN/wp-content/plugins/wp-defender/changelog.txt
    [Thu Jun 08 07:37:56.042390 2017] [access_compat:error] [pid 20418] [client xxx.xxx.xxx.xxx:42862] AH01797: client denied by server configuration: /[ROOT]/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://www.DOMAIN/wp-content/plugins/wp-defender/changelog.txt
    [Wed Jun 07 22:00:03.982970 2017] [access_compat:error] [pid 339] [client xxx.xxx.xxx.xxx:55796] AH01797: client denied by server configuration: /[ROOT]/public_html/wp-content/plugins/wp-defender/changelog.txt, referer: https://www.DOMAIN/wp-content/plugins/wp-defender/changelog.txt
    [Wed Jun 07 21:35:35.880238 2017] [access_compat:error] [pid 333] [client xxx.xxx.xxx.xxx:45636] AH01797: client denied by server configuration: /[ROOT]/public_html/beta/wp-content/plugins/wp-defender/changelog.txt, referer: https://www.DOMAIN/beta/wp-content/plugins/wp-defender/changelog.txt
    [Wed Jun 07 20:35:25.836142 2017] [access_compat:error] [pid 405] [client xxx.xxx.xxx.xxx:34074] AH01797: client denied by server configuration: /[ROOT]/public_html/beta/wp-content/plugins/wp-defender/changelog.txt, referer: https://www.DOMAIN/beta/wp-content/plugins/wp-defender/changelog.txt
    [Wed Jun 07 19:35:15.860512 2017] [access_compat:error] [pid 28107] [client xxx.xxx.xxx.xxx:34284] AH01797: client denied by server configuration: /[ROOT]/public_html/beta/wp-content/plugins/wp-defender/changelog.txt, referer: https://www.DOMAIN/beta/wp-content/plugins/wp-defender/changelog.txt
    [Wed Jun 07 18:35:05.718285 2017] [access_compat:error] [pid 28112] [client xxx.xxx.xxx.xxx:43064] AH01797: client denied by server configuration: /[ROOT]/public_html/beta/wp-content/plugins/wp-defender/changelog.txt, referer: https://www.DOMAIN/beta/wp-content/plugins/wp-defender/changelog.txt

    Mahlamusa

    Hi OWM Admin,

    There is indeed nothing related to Snapshots in the debug.log file you shared. Did you have a chance to raise the limits as I described in the above post? I think at this point it is better to send access credentials to your hosting control panel so we can have a closer look at your server settings.

    I did notice:
    - /wp-admin/admin.php?page=snapshots_full_backup_panel shows "Automatic backup currently running"

    That means at this particular point in time the automatic backup is running (still processing) but not yet complete. In the managed backups page, there is a link to view logs specific to snapshot, please view those and see if there are any useful details there. In order to get the most useful information from the Snapshot logs, you should set debug mode to "Info" so that snapshot will log all steps it takes, this will make it easier for us to trace if there is any issue.

    It will be great if you provide access to your site and hosting control panel so we can have a look. You may send this info via our secure contact form. on the contact form, choose "I have a different question", then

    in the "Subject" line write: "Attn: Lindeni Mahlalela", and
    in the "Message" box add the following:
    - WordPress login details (login url, username and password)
    - cPanel / Hosting Control Panel login details: login url, username and password
    - Link back to this thread for reference.

    Once we have this we will continue to investigate this further.

    Cheers,
    Mahlamusa

    OWM admin

    > I Added the following to wp-config.php
    define( 'WP_MEMORY_LIMIT', '256M' );

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);

    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);

    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);

    > In cPanel, I went to "Software > MultiPHP INI Editor", choose my domain and PHP version and changed the value for max_execution_time to 300

    > Cpanel and WP Admin credentials have been shared via secure form

    Of course, if you make ANY config changes please document them carefully so that I have a log of changes should any changes to fix this issue cause other issues down the road. Thanks for your assistance.

    Mahlamusa

    Hello OWM admin,

    I am really sorry for the delay here but I want you to rest assured that the issue is being investigated. I am the one who created a Snapshot to test something. I will update here once I have found a solution to the issue. Currently I am running multiple configuration combinations to find the most appropriate configuration for your server.

    In most cases, snapshot works with the default settings but there are rare cases like this one where we have to find a unique configuration specific to the website and the underlying server architecture.

    If you do not mind, please update WordPress and Snapshot to the latest version as there are some useful features in the updated version.

    We really appreciate your patience regarding this and we hope to find a solution soon.

    Cheers,
    Mahlamusa