Scheduled backups aren't happening

The scheduled backups are not being created. I set the schedule for backups to be created, but this is not happening.

  • Nazmul H. Rupok
    • The Incredible Code Injector

    Hi there,

    I hope you are doing great today and thank you for contacting us. I am sorry that Snapshot Scheduled backups are not working well for you.

    Please allow support access so we can have a closer look at this on your end.
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please respond in this thread once access is granted.

    For the time being, please do the following for me which is a major step towards resolving the issue:

    1. Enable debug logging. You can do this by adding the following lines to your 'wp-config.php' file:

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    2. Increase WordPress memory limit:

    define( 'WP_MEMORY_LIMIT', '256M' );

    3. dd the following lines which are specific to Snapshot settings:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);

    4. Increase max execution time to 300 or more by trying the following methods.
    a. Create or edit php.ini in your website's root and add the following line:
    max_execution_time 300

    b. In .htaccess add the following line:
    php_value max_execution_time 300

    c. in cPanel you can go to "Software > MultiPHP INI Editor", choose your domain and PHP version and change the value for max_execution_time to 300 or more

    After that you can try Snapshot again, please try to set it to "Daily" so that we can have results soon for the Scheduled Backups, you can change later.

    Let me know how it goes.

    Best regards,
    Nazmul

  • Nazmul H. Rupok
    • The Incredible Code Injector

    Hi there,

    Hope you are doing well.

    https://premium.wpmudev.org/contact/#i-have-a-different-question
    Please visit our private Contact page and complete the form with the following information:

    Subject: "Attn: Nazmul"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login (disregard if you already enabled access):
    Admin username
    Admin password
    Login url

    - htaccess credentials
    username
    password

    Best regards,
    Nazmul

    • Nazmul H. Rupok
      • The Incredible Code Injector

      Hi One North

      Hope you are doing well. Let me explain this a bit for you. There are two kind of backups in Snapshot plugin, one is "Snapshot" which is done manually (and interval could be set) where you can choose your files and database and other one is "Managed Backup" which automatically backup your entire website on a regular basis and store those backups on WPMU DEV's secure cloud servers.

      So in order to schedule a backup, you should enable managed backup. So clarify which one you are exactly referring.

      Hope this makes sense. If you have any question, let me know.

      Have a nice day. Cheers!
      Nazmul

  • One North
    • Flash Drive

    Hey Nazmul - that doesn't seem right to me. I understand the managed backup functionality, but in my experience you don't necessarily need to enable that functionality in order to schedule automated daily backups. I have another multisite instance (http://gibbonsmswp.wpengine.com/) that is using Snapshot Pro. I have once daily snapshots scheduled and enabled, and they are completing and uploading to my Amazon S3 cloud storage bucket without any issues. I do NOT have managed backups enabled for that site. I have configured the snapshots on https://lockelordmswp.wpengine.com/ the same way, yet those scheduled jobs never kick off -- which is what I'm trying to get resolved. Does that make sense?

    Just in case you want to see how everything is configured (and working) on http://gibbonsmswp.wpengine.com/, I have enabled support access.

  • Nazmul H. Rupok
    • The Incredible Code Injector

    Hi One North

    Hope you are doing well. I am sorry for the confusion as you said managed backup. I see you are referring the scheduled snapshot that you have set for daily interval which seems working fine.

    As I can see last cron ran on June 17, 2017 5:34 am and next will run on June 18, 2017 5:30 am which appears to be fine. Would you clarify what's not working?

    Have a nice day. Cheers!
    Nazmul

  • One North
    • Flash Drive

    It looks like they started working again on 6/14/2017, which coincides with when I disabled the username/password. So I'm guessing that was causing the issues. I'll remember that if I run into similar issues in the future. You can close this ticket now -- thanks for your help!!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.