Scheduled Backups Not Working

I've set my Snapshot Pro plugin to backup daily, however, it hasn't backed anything up since setting it up, and I've had to do it manually every time. Is there a setting I'm missing somewhere?

Thanks!
Seth

  • Majid

    Hello Seth
    I hope you are having a nice day :slight_smile:

    Snapshot scheduled backups rely on the wp-cron jobs to be enabled on you WordPress install. You can try enabling them by editing the wp-config.php and adding this line of code
    define('DISABLE_WP_CRON', false);
    Above the line that says /* That's all, stop editing! Happy blogging. */

    You can read more about it here: How to Enable WP Cron

    Once that done, you will notice that the scheduled backups are running if the issue was caused by the crons being disabled, otherwise let us know in a reply and we will debug further the issue.

    Cheers,
    Majid

  • Dimitris

    Hello there Seth,

    hope you're doing good today! :slight_smile:

    Could you please clarify to me, is this about normal snapshots or managed backups?

    For the later one, please edit wp-config.php file and add the followings, just above the /* That's all, stop editing! Happy blogging. */ comment:

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_IGNORE_SYMLINKS',true);

    For either type of backup, also activate WP debugger the same way, editing wp-config.php file, just above the /* That's all, stop editing! Happy blogging. */ comment:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    After doing so, please do install and activate the following plugin (WP Crontrol)
    https://wordpress.org/plugins/wp-crontrol/

    Then try to re-schedule daily, and let us know how that goes.
    If the issue continues, please do attach in your next reply wp-content/debug.log file (if size of text file exceeds the 5MB limit of our blog, please use a service like Dropbox and post the shareable link instead).

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.