Screwed up Subscriptions Page Formatting - Needs Fix!!!

Hi there once again.

In the ongoing saga of our new forum site, we're getting close to working all the bugs out (I think), but there is one glaring problem I don't I can do anything about.

In short, the Subscription page looks terrible, and it's basically unusable once somebody tries to use it. See attached screenshots:

https://skitch.com/internetmarketing/ew1kd/subscriptions

https://skitch.com/internetmarketing/ew1kq/subscriptions

This page looked good once upon a time. Each level of membership had it's own shadow box, and it was clear and clean. Now it's all a jumble and I don't think it's anything we did. I'm already getting complaints from testers.

How can this be fixed?!?!? And how soon? I can tell you right now we will lose potential members over this. They will get confused and frustrated and just leave, never to be seen again.

  • karl_s
    • Site Builder, Child of Zeus

    Hey Mason!

    Thanks for jumping in here! I would be happy to show you the page... unfortunately, you will not be able to see it until you become a member. Though I doubt I'm telling you anything you don't already know.

    :wink:

    I should advise you that another fine WPMU guru (Joe/aecnu) is already a member (twice now). He's trying to help me sort out all the Membership/Subscription problems we've been having.

    Just go to UFOEXT.com and then to the Register tab.

    I'll be thrilled if we can get this sorted, as it's going to be a major impediment (and source of headaches) otherwise.

    Thanks, brother. :smiley:

    -- Karl

  • Mason
    • DEV MAN’s Sidekick

    Hiya Karl,

    Ok, took a look and you'll just need to add more spacing to the pricedetails class.

    The following code should be added wherever you're implementing custom CSS. If you have no idea what that means, install this plugin:
    http://wordpress.org/extend/plugins/my-custom-css/

    Then add something like the following:

    .pricedetails {
        border: 1px dotted;
        padding-bottom: 10px;
        padding-top: 10px;
    }

    Of course, there's infinite ways to customize it, but hopefully that helps you get started. If you want some expert coders to assist (at a reasonable price) check out http://tweaky.com.

    Hope this helps. Let us know if you need anything further!

  • karl_s
    • Site Builder, Child of Zeus

    Cool.

    I will try the plugin and the code.

    What I don't understand is why it was working before and is not working now? Is there some conflict somewhere? Any thoughts?

    I presume that a plugin will make changes more or less permanent? My concern is the next upgrade of the theme. Am I going to have to manually tweak this every time there is an upgrade?

    Thanks, brother.

  • karl_s
    • Site Builder, Child of Zeus

    Hey Mason.

    I just tried the plugin and the code you suggested.

    Result? We are definitely making progress. I can now add CSS Master Coder to my list of accomplishments (ahem).

    Anyway, it now looks 100% better - thanks to you. However, it's still not quite right.

    See screenshot: https://skitch.com/internetmarketing/ew6ka/subscriptions-ufo-ext-forum

    Can you provide me a bit more coding help to correct for the issues shown in the screenshot? If you can, we should be good to go and I'll get out of your hair!

    :wink:

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    I figured that was gonna be the case, but I can't actually see the subscribe buttons. Can you make sure my username (mason) is 'active' in membership. I should then be able to see the buttons and provide assistance.

    What I don't understand is why it was working before and is not working now? Is there some conflict somewhere? Any thoughts?

    I'm not totally sure what you're referring to here. What was working before?

    I presume that a plugin will make changes more or less permanent? My concern is the next upgrade of the theme. Am I going to have to manually tweak this every time there is an upgrade?

    That's why I recommend using a separate plugin. You can update our plugin and even change themes, but those stylings will remain safely and separately in the database. :slight_smile:

  • karl_s
    • Site Builder, Child of Zeus

    Hey man!

    You are definitely showing as "active" (in green) - and have been, as far as I know. You should be able to see the buttons! Hmmmm. That's weird that you can't. Can you look again?

    FYI, I added you to Sustaining level membership, which is the first paid level. I figure that might help give you a better look at things (?). I can also make you a full Membership admin if you really want to get under the hood.

    What I was referring to about "working before" was the box styling on the Subscribe page. The page had some really nice styled boxes with a border, rounded corners and a drop shadow. It looked great. Now it's gone entirely! I surely don't know why.

    I'm glad to hear the plugin will do what you describe. Brilliant! I didn't even know it existed. But then again, I haven't been tweaking code till now. It's always something new with WP! :slight_smile:

    I hope you can see what you need to see now.

    Thanks, Mason!

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    I've logged in and out multiple times and see that I have a level assigned to me but don't have upgrade options available.

    If you're able to see the buttons though you can fix this yourself by following the same properties I outlined above for the Price Details.

    Firebug is an extremely popular tool used by front-end developers everyday to take a look at the live code on a site and figure out the best way to implement what you want (and it's totally free!)

    There's a great writeup on Firebug here: http://www.studiopress.com/tips/using-firebug.htm

    If you need assistance with something specific we can try to help here or for fast, reasonable customizations we recommend http://tweaky.com.

  • karl_s
    • Site Builder, Child of Zeus

    Hi Mason.

    Gah! This damn Membership thing is the fiddliest freakin' thing I've ever run across. You were not setup under the right Gateway, which is what Joe and I have been trying to get straightened out and which has been making my life hell.

    Could I bug you to take one more look? I could really use the expert feedback, as telling me to go use Firebug means I'm yet further away from getting this addressed... because it's yet another new thing I've gotta look at and learn in order to fix this!

    You should have the buttons visible to you now. Under the other Gateway, you wouldn't have, because you weren't actually subscribed to anything. Now you are. It should work for you this time.

    Thanks in advance if you can address this one more time.

    Regards,
    Karl

  • Mason
    • DEV MAN’s Sidekick

    Building off what we had before try this:

    .pricedetails {
        padding-bottom: 10px;
        padding-top: 50px;
    }
    #membership-wrapper legend {
        line-height: 1;
    }

    I'm wondering if there's something in the formatting of your subscription details that's causing things to not lineup properly. On a regular Membership subscription page these things look pretty good/clear.

    hope this helps. Thanks!

  • karl_s
    • Site Builder, Child of Zeus

    I'm wondering the same thing (well, sort of, in less precise terms). I was hoping you could tell me.

    In the meantime, I'll give this a go.

    Thanks brother. You ROCK! I really appreciate your kind help and patience.

    :smiley:

  • karl_s
    • Site Builder, Child of Zeus

    Well, that was an interesting exercise...

    But it didn't appear to do anything. As in... at all!

    Would it help you to have admin access, Mason? Do we need to hire a coder at this point? You tell me.

    Thanks, man.

  • Mason
    • DEV MAN’s Sidekick

    Hiya @karl_s,

    Did you remove the original code I gave and replace it with the new set? I'm still seeing the old ones in there.

    That should do it for you, but there are always several ways to code something to give the exact look you want. I've found services like http://tweaky.com to be well-equipped to handle requests such as this quickly.

    Are you using the custom css plugin I mentioned to do this? Let me know if the above doesn't work for you.

  • karl_s
    • Site Builder, Child of Zeus

    Hey Mason! Thanks again for your help and patience. Seriously!

    I had done as you asked but I had played around with the code and added another "margin" which didn't seem to help but which seemed to screw up your corrections.

    Here's where the code is now:
    http://www.flickr.com/photos/87782379@N03/8034060439/

    Here's what the subscription page looks like:
    http://www.flickr.com/photos/87782379@N03/8034076875/

    I added the 50 pt margin to the bottom, rather than the top, because I thought that might "include" the buttons. But all it's doing either way is opening up space inside the box.

    However, all of this may be for nought...

    Be advised that there may be something really wonky going on here. Joe just got back to me and he has concluded that there is definitely something wrong with my site. The Membership plugin signup process is not working right. I'm hoping he can get to the bottom of it, since it's way beyond my pay grade. I tell you this because perhaps the same thing that's messing with the subscriptions, payment gateways and signups is screwing up the code, too. What do you think?

    If you think that might be the case, we should probably table any further attempts to fix this until Joe and I can get to the bottom of the more pressing problem.

    Regards,
    Karl

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Those images are marked as private, so I don't have the ability to view them :disappointed:

    Bummer this is still an issue. In the code I posted above I removed the dotted-line border because it's circling the wrong information. So if you're only using the code I provided you should not have a dotted line.

  • karl_s
    • Site Builder, Child of Zeus

    Gah!

    The simple things confound the wise. Evernote totally f'd Skitch, so I switched over to a Skitch-like app called Voila, which uses Photobucket instead of it's own servers to display pics. Naturally, I assumed that when I uploaded to Photobucket it worked like Skitch. NOT! The grabs were set to "Private." Sorry about that. You must hate me by this point.

    :-o

    I was using a hybrid of the new code and the old code in the last round. It's now set to exactly what you sent.

    Anyway, here's the latest (you should be able to see this one, and I fixed the other grabs so you can now see them (if you still care)).

    http://www.flickr.com/photos/87782379@N03/8041316216/

    Again, thanks Mason.

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    Ok, so I'm now wondering if there's info in the subscription areas themselves that are causing this to be all out of sorts. Unfortunately there's no way for me to tell without being able to login to your admin area and see for myself.

    If you're ok with that you can just make my username an admin (AND a membership admin) and I'll log back in and see if I can find what's causing the weird layout issues.

    Let me know if that's acceptable. Thanks.

  • karl_s
    • Site Builder, Child of Zeus

    Hey Mason!

    Cool. I offered to "let you in," and I'm happy to do it.

    You are now good to go. I just modified you to full Admin status and Membership Admin status as well.

    Feel free to poke around and tell me if you find anything wrong, screwed up or in need of attention. I'm definitely not a WP noob, but when it comes to forums, Membership plugins and the like, I am! Who knows what I may have screwed up?

    Please bear in mind that Joe is looking at the actual subscription/membership/payment issues we're having. But you are more than welcome to weigh in if you see something that needs to be addressed.

    Thanks, brother.

    :smiley:

  • karl_s
    • Site Builder, Child of Zeus

    Good news, Mason!

    Joe/aecnu has figured out what was dogging the site in the subscriptions/Membership area, and whatever he did seems to have sorted out the problem you were working on.

    So, it's a twofer! Problem solved!!!

    Thanks for all your patience and help, man. I'm sure it's been really aggravating at times, but know that it's much appreciated!

    You and WPMU rock! Points awarded. Muchos gracias!

    :smiley:

  • Patrick
    • Support Monkey

    Hey @karl_s

    Just a heads-up :slight_smile:

    I'm doing a bit of house-cleaning today and archiving threads that are either old, or haven't been marked resolved yet.

    If you need more help with this, or any other WPMU DEV product, please feel free to re-open this one or start a new topic.

    Have a great day!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.