Scribe theme: won't save changes during set up

I'd like to try using the Scribe theme for this site but when I try to save the changes I get an error -- it says something to the effect of "there has been an error, some changes were not saved."

I also can't quite figure out how to return to the admin area when I'm done with the customization screen.

  • Adam Czajczyk

    Hello Lorie,

    I hope you're well today and thank you for your question!

    As for going back to admin area. Once you done with your customization please click on a little "exit" icon next to "upfront" label on top of Upfront panel on the left (see screenshot). This will exit Upfront editor and load your page. You can then access your /wp-admin e.g. by clicking on "Dashoard" item of your admin toolbar (see screenshot).

    "there has been an error, some changes were not saved."

    I'd like to take a closer look and test it myself. Would you mind granting me a support access to your site via our WPMU DEV Dashboard? To do this please follow this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Lorie

    Hey Adam --

    I did eventually notice the exit icon -- but then I wished it allowed me to actually go somewhere other than the home page of the site. I almost never want/need to see that or the actual dashboard page. When I'm done with editing something I like to move directly on to the next item on my agenda (yes, I'm being finicky now). This is probably the first the new WP install since the Customizer became a mandatory thing so I have a lot to get used to (especially since I never really liked the Customizer -- it didn't save changes either).

    I'll have those access permissions granted in a few minutes. Or less. :slight_smile:

    Edited to add: Access granted. Another issue I've noticed, which may or may not be related to Upfront/Scribe -- the title bar in the browser tab is stuck on "Manage Themes" no matter what page I'm actually working on. Any ideas about where that is coming from or how to fix it?

  • Adam Czajczyk

    Hello Lorie,

    Thank you for granting access. I've visited your site and tested it and I admit I'm a bit puzzled here. That's pretty fresh and almost empty (in terms of additional plugins) install with pretty high PHP memory available. The site itself is loading quite fast, yet it's giving that error. One of my colleagues checked that also but he was not able to diagnose the issue as well.

    That said, I turned to Upfront developers and ask them for helping hand. We'd need however to wait for any of them to get back online (we're a global team working from different time zones). Please keep an eye on this thread and I'll get back to you as soon as I get a response/suggestions from them.

    Best regards,
    Adam

  • Lorie

    Okie dokie. We're still trying to get everything else worked out for the site, so it isn't critical yet to have the theme up and running. Probably within a few days I'll have to switch to something else (at least temporarily) if it takes that long to figure out. I'm glad it wasn't working for all y'all, usually it's just me. I haven't had any luck with the Customizer since around the time it became mandatory rather than the theme options page.

  • Adam Czajczyk

    Hello Lorie,

    Thanks for letting me know about that. Knowing that the Update was just release I was hoping that it will fix the issue. I wasn't able to replicate this on any of my test setups but I believe that's because of my server that most likely differs significantly from yours.

    That said, I did notice one other significant difference here. I'd like to ask you to change PHP version if possible. I can see that your server is currently running the 5.4.45 version which is pretty outdated already.

    Either via the control panel of your server (probably that'd be cPanel) or with a little help of your hosting provider you should be able to switch to a newer PHP version. I know from my own experience that Upfront should run fine on 5.6.19 version in most cases (my test site that I'm using the most is also running that version) but if it's possible to use even never (including 7.x) version then please give it a try.

    Let me know please if it helped!
    Best regards,
    Adam

  • Lorie

    Quick update:
    I just installed and activated Scribe on one of my own sites and had no problems making changes to it. Since I use a different hosting company, it stands to reason that the source of the problem must lie somewhere on the hosting server. That's kind of out of my comfort zone, but if y'all have ideas of other changes to make that can be done through cPanel I'll give them a try. Thanks in advance for your help with this.

  • Adam Czajczyk

    Hey Lorie,

    Thanks for this information!

    I think there's another thing worth trying. It was suggested to me that this may be caused by Apache's "mod_security" module. I didn't thought of this because usually "mod_security" issues were giving a bit different symptoms.

    A word of explanation :slight_smile: Apache is a software on the server that serves your website and "mod_security" is a module of Apache that in some ways "cares for security" of your site (and a server).

    It's possible that the "mod_security" module is blocking certain requests to the server made by Upfront scripts.

    1. First thing worth trying would be to edit your site's ".htaccess" file by adding these lines to it (at the beginning):

    <IfModule mod_security.c>
      SecFilterEngine Off
      SecFilterScanPOST Off
    </IfModule>

    2. If this doesn't work, create an empty ".htaccess" file inside the "/wp-admin" folder of your site and put the same code there.

    3. If this doesn't work still, replace that code in your site's main ".htaccess" file with this one:

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    4. If this doesn't work repeat step 3 for "/wp-admin/.htaccess" file that you previously created

    5. If this doesn't work, replace that code in your site's main ".htaccess" file with this one:

    <IfModule mod_security.c>
      SecRuleEngine Off
      SecFilterInheritance Off
      SecFilterEngine Off
      SecFilterScanPOST Off
      SecRuleRemoveById 300015 3000016 3000017
    </IfModule>

    6. If this doesn't work still, repeat step 5 for "/wp-admin/.htaccess" file

    Finally, if none of that helps, please get in touch with your host and ask them whether the "mod_security" is enabled on the server and if so if they could either disable it for your domain or check what traffic generated by Upfront it is blocking and if it could be "white listed".

    Let me know what was the result of this, please.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.