Second administrator unable to upgrade WPMUDEV plugins

Hi

Most of my websites have a second administrator to help me with upgrades etc but he is unable to upgrade the WPMUDEV Smush Pro plugin (insufficient priveleges message). Is there anything that can be done about this?

thanks
Mariette