Secure login error

When using login-image with secure login, IE throws a mix-content warning because the image link in the Login-Image plugin is hardcoded as "http://...". Though not very elegant, I changed that link to https:// and the warning goes away. It would be nice if that could be automatic or be set as an option in the plugin itself.