Security

I was alerted to change the database prefix, disable file editor, Prevent PHP execution etc...

I went through and made the adjustments it recommended and then it deleted my site, installed a new wordpress.

I notice that the old site is still in the files. How do I make it come back up?

  • Rupok

    Hi Will, hope you had a wonderful day.

    Can you please tell us which plugin you are using for security? Is it WP Defender? I did all the things Defender suggested me to do but my site was not deleted. As you said your old site is still in the files, can you please mentions what type of files you are seeing there? Your old images and other files you uploaded or any zip archive? It's pretty tough to conclude anything without seeing your files actually.

    Or, if you want to continue with your new WordPress site, can we try to fix those points Defender is suggesting in your site and check if the site is *deleted* again? I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!
    Rupok

  • Kasia Swiderska

    Hello Will,

    I'm not going to change those settings as this is live site and I could replicate the same issue you are having and without access to your files I wont be able to fix that.
    My suspicion is that for some reason when you changed prefix for database it was changed but not in the wp-config.php file - that is why WordPress wanted to install again - because prefix in config was not the same as in database.
    Opposite situation is also possible - Defender was not able to change prefix in database, but was able to change it in wp-config.php - effect will be the same - different prefixes and WordPress will try to do fresh install.

    In that case files will be the same.

    If you can - please try again changing prefix and then check database if tables have new prefix and if the prefix is the same in wp-config.php. When you see that tables have new prefix but config not then you can manually change it there.
    When tables don't have new prefix - you can still change it in the wp-config.php to old one.

    Of course, please take backup of the database before any changes and let me know about the results.
    Also please enable debug mode in WordPress before this - if there is error preventing change in one place then we will know what went wrong. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see content of the debug.log file - so please paste it to the text file and attach to post.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.